
  










<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.tetonvalleynews.net/content/tncms/live/" />
<meta name="tncms-access-version" content="2021-09-22 19:09:43" />
<meta name="tncms-access-criteria" content="{&quot;c0334d48-e418-11eb-a238-23370cc94cbf&quot;:[&quot;a280fca2-e416-11eb-a238-535408e82ab0&quot;],&quot;989b0410-e418-11eb-a238-e371e58201e4&quot;:[],&quot;0e0d1c62-e41c-11eb-ae08-cff7382c14b5&quot;:[],&quot;e372b15a-e417-11eb-a238-b7282fce0eb6&quot;:[],&quot;4b9da520-0531-11ec-ae08-9fb17a041b5c&quot;:[],&quot;3e4a2464-e418-11eb-a238-7fc1e541b0f2&quot;:[],&quot;269faab6-0531-11ec-ae08-3fa3b4f1ea64&quot;:[],&quot;61c7746e-e418-11eb-a238-ef2806bd9cb0&quot;:[],&quot;e99c3b2a-0530-11ec-ae08-4beaf2ed1f13&quot;:[],&quot;c5ceb9ca-0530-11ec-ae08-cfb5d553ac9c&quot;:[],&quot;904ae75e-e41c-11eb-ae08-7f9cc06c5410&quot;:[],&quot;66ee3c62-e41c-11eb-ae08-eff523988422&quot;:[],&quot;a35f3a2c-0530-11ec-ae08-03c86f032279&quot;:[],&quot;ec9130da-e418-11eb-a238-e75364e03977&quot;:[&quot;00b4b4ae-e416-11eb-a238-e7b86716ced1&quot;,&quot;e49137ca-e415-11eb-a238-c7b9860d34fa&quot;],&quot;7d27ef66-0530-11ec-ae08-affff82b0396&quot;:[&quot;00b4b4ae-e416-11eb-a238-e7b86716ced1&quot;,&quot;e49137ca-e415-11eb-a238-c7b9860d34fa&quot;],&quot;141dcf46-e419-11eb-a238-0328cae74f75&quot;:[&quot;00b4b4ae-e416-11eb-a238-e7b86716ced1&quot;,&quot;e49137ca-e415-11eb-a238-c7b9860d34fa&quot;],&quot;558bf7d6-0530-11ec-ae08-532537c43962&quot;:[&quot;00b4b4ae-e416-11eb-a238-e7b86716ced1&quot;,&quot;e49137ca-e415-11eb-a238-c7b9860d34fa&quot;],&quot;3a100660-e419-11eb-a238-0b759f09d848&quot;:[&quot;00b4b4ae-e416-11eb-a238-e7b86716ced1&quot;,&quot;e49137ca-e415-11eb-a238-c7b9860d34fa&quot;],&quot;64dec368-e419-11eb-a238-d74c0171816c&quot;:[&quot;00b4b4ae-e416-11eb-a238-e7b86716ced1&quot;,&quot;e49137ca-e415-11eb-a238-c7b9860d34fa&quot;]}" />
<meta name="tncms-criteria-ids" content="a280fca2-e416-11eb-a238-535408e82ab0,00b4b4ae-e416-11eb-a238-e7b86716ced1,e49137ca-e415-11eb-a238-c7b9860d34fa" />
<meta name="tncms-access-asset-app" content="editorial" />
<meta name="tncms-access-asset-id" content="1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a" />
<meta name="keywords" content="ava kelly, teton valley foundation, economics, sport, donation, test, covid vault, ava marie yogi, teen" />
<meta name="news_keywords" content="ava kelly, teton valley foundation, economics, sport, donation, test, covid vault, ava marie yogi, teen" />
<meta name="description" content="Like many communities across the country, Teton Valley is coping with a shortage of Covid tests in the midst of an Omicron upswing. When she learned of this challenge to" />
<meta name="author" content="Julia Tellman" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="googlebot" content="noarchive" />
<meta name="google-site-verification" content="ap5ifIwzCri0btebSI96V9l7A5PC0-BsoABTt4F0J4k" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.tetonvalleynews.net/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?crop=1246%2C654%2C0%2C503&amp;resize=1200%2C630&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Victor teen donates 400 Covid tests to community" />
<meta property="og:description" content="Like many communities across the country, Teton Valley is coping with a shortage of Covid tests in the midst of an Omicron upswing. When she learned of this challenge to" />
<meta property="og:site_name" content="Teton Valley News" />
<meta property="og:section" content="Home" />
<meta property="fb:app_id" content="2959550254137794" />
<meta property="article:publisher" content="http://www.facebook.com/TetonValleyNews" />
<meta name="twitter:image" content="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?crop=1246%2C654%2C0%2C503&amp;resize=438%2C230&amp;order=crop%2Cresize" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@http://www.twitter.com/TetonValleyNews" />
<meta name="twitter:image:alt" content="20220122_174404.jpg" />
<meta property="tncms:subs" content="3.0" />
<meta property="tncms:ads" content="smart,lazyload,refresh" />
<meta name="twt-site-id" content="000001737d53d1d1_c7b1e50" />
<meta name="twt-article-id" content="1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a" />
<meta name="twt-author-name" content="jtellman@tetonvalleynews.net" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.c58a1beaa3640fa94c3db09673c4d95c.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.2ce6292643f5129895871a2478a4614d.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.feb84265ed22ec1b578ffb91ddb31be4.css"/>
<link rel="stylesheet" href="global/resources/styles/site.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Raleway:400,700,600|Open+Sans:300,400,700&amp;display=swap"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/styles/tnt.access.offers.893b4c78f7e38b706f17982f17b623ce.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/styles/datepicker3.9f2593097fc3849b80bb9d187a12b345.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-promo-button.52347555fbb6668223efabadb9c9d111.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.61.0"},"crm":{"group_id":"287"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"centerpiece","style":"default","path":"\/freeaccess","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"asset":{"author":"Julia Tellman","presentation":null,"start_hour":"09","id":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a","app":"editorial","ga_page":"\/freeaccess\/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"},"vendor":{"outbrain":"disabled","taboola":""},"system":{"render_time":248},"client":{"is_bot":"no","is_gdpr":"no"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.61.0"},"crm":{"group_id":"287"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"centerpiece","style":"default","path":"\/freeaccess","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"asset":{"author":"Julia Tellman","presentation":null,"start_hour":"09","id":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a","app":"editorial","ga_page":"\/freeaccess\/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"},"vendor":{"outbrain":"disabled","taboola":""},"system":{"render_time":248},"client":{"is_bot":"no","is_gdpr":"no"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PFQH52B');})();</script>
<script src="https://tags.crwdcntrl.net/c/9940/cc.js?ns=_cc9940" id="LOTCC_9940"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc9940.add('tp', 'TNNW');
		_cc9940.add('act', ' User Login');
		_cc9940.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc9940.bcp();
</script>

<script type="module" async="async" src="/shared-content/art/tncms/api/access.js"></script>
<script src="/shared-content/art/tncms/api/access-legacy.js" defer="defer" nomodule="nomodule"></script>
<script>/*<![CDATA[*/ window.TNCMS = window.TNCMS || {};window.TNCMS.Access = window.TNCMS.Access || [];(function (callback) { var oScript; var oStorage; try { oStorage = JSON.parse(sessionStorage.getItem('tncms.dmp.audiences')); if (!oStorage || !oStorage.audiences || !oStorage.expired) { throw "Not in session storage"; } if (oStorage.expired < new Date().getTime()) { sessionStorage.removeItem('tncms.dmp.audiences'); throw "Cache is expired"; } callback(oStorage.audiences); } catch(oException) { if (!window.tncms_siteaud) { window.tncms_siteaud = null; } oScript = document.createElement('script'); oScript.onerror = function() { callback([]); }; oScript.onload = function() { try { var oResult = { audiences:[], expired: new Date().getTime() + 86400000 }; if (!window.tncms_siteaud) { return; } for(var nIdx = 0; nIdx < window.tncms_siteaud.Profile.Audiences.Audience.length; nIdx++) { var sAbbr = window.tncms_siteaud.Profile.Audiences.Audience[nIdx].abbr; oResult.audiences[oResult.audiences.length] = sAbbr; } oResult.audiences.sort(); sessionStorage.setItem('tncms.dmp.audiences', JSON.stringify(oResult)); } catch(oException) { if (console && console.warn) { console.warn('Failed to add behaviors to session storage'); } } callback(oResult.audiences); }; oScript.setAttribute('async', true); oScript.setAttribute('src', '//ad.crwdcntrl.net/5/c=9937/pe=y/var=tncms_siteaud'); var aHead = document.getElementsByTagName("head"); if (aHead && aHead[0]) { if (TNCMS && TNCMS.Tracking) { var oTracker = TNCMS.Tracking.createBucket({ 'app': 'tncms-dmp', 'metric': 'audience-extraction', 'data': { name: 'client', value: 9937 } }); oTracker.addEvent(new Date().getTime()); } aHead[0].appendChild(oScript); } } })(function(aAudiences) { window.TNCMS.Access.push(function() { TNCMS.Access.setAudiences(aAudiences); });}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d6d18fcf88750a16d256e72626e676a6.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.394adeeb6831ca20cb80bc3489a2f345.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.cb897187c4718280fd69d2e6d6c3909d.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/bootstrap-datepicker.2b28bee684315ebcadec4a6b63cc146d.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.mask.84bef41f682a27dac3fd6e812c06365d.js"></script>
<script version="1" src="https://www.google.com/recaptcha/api.js?onload=signupVkCallback&amp;render=explicit"></script>
<script src="https://core.spreedly.com/iframe/iframe-v1.min.js"></script>
<script version="1" src="https://www.google.com/recaptcha/api.js?onload=SpreedlyvkCallback&amp;render=explicit"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.status.828de94349981272665c0fb0107f3e49.js"></script>
<script>/*<![CDATA[*/ __tnt.subscription.access.status.check(function(data){
    /* time to consume tracker - time in seconds: 53 */
    setTimeout(function(){
        __tnt.log("Access - validated user view");
        _cc9940.add('act', read_article);_cc9940.bcp();
    }, 26500);
}); /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.7a9170240d21440159b9bd59db72933b.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.dmp = __tnt.ads.dfp.dmp || {};
    __tnt.ads.dfp.dmp.audienceCheck = function(settings) {
        if (!__tnt.client.capabilities.supportsLocalStorage() || localStorage.getItem('tncms.dmp.audiences') == null) return false;
        if (settings.block && typeof settings.audience != 'undefined' && settings.audience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), settings.audience.split(','))) return true;
        } else if (typeof __tnt.ads.dfp.dmp.hideAudience != 'undefined' && __tnt.ads.dfp.dmp.hideAudience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), __tnt.ads.dfp.dmp.hideAudience)) return true;
        }
        return false;
    };

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["ava kelly","teton valley foundation","economics","sport","donation","test","covid vault","ava marie yogi","teen"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        cube:"https:\/\/bloximages.chicago2.vip.townnews.com\/tetonvalleynews.net\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/cube.d862aac30e9cb24516c7474509403c47.js",
        interstitial:"https:\/\/bloximages.chicago2.vip.townnews.com\/tetonvalleynews.net\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.7047e23fde50ef7dc7625903de95abec.js",
        nativeArticle:"https:\/\/bloximages.chicago2.vip.townnews.com\/tetonvalleynews.net\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/native-article.9b3cd3bb8591bed71346f4fe429b96dc.js",
        pageCurl:"https:\/\/bloximages.chicago2.vip.townnews.com\/tetonvalleynews.net\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.chicago2.vip.townnews.com\/tetonvalleynews.net\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.chicago2.vip.townnews.com\/tetonvalleynews.net\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.3dd6ca40ac90c6df07356392c8489f72.js",
        pencil:"https:\/\/bloximages.chicago2.vip.townnews.com\/tetonvalleynews.net\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.8cf6eeafd9d2d9371b611e86c7c099c1.js",
        reveal:"https:\/\/bloximages.chicago2.vip.townnews.com\/tetonvalleynews.net\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        roller:"https:\/\/bloximages.chicago2.vip.townnews.com\/tetonvalleynews.net\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/roller.c699c542afb9f08b38613e8473ddf14f.js",
        stickyAnchor:"https:\/\/bloximages.chicago2.vip.townnews.com\/tetonvalleynews.net\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/sticky-anchor.6dc181cbc3d60e2a1892d05998349ef6.js",
        video:"https:\/\/bloximages.chicago2.vip.townnews.com\/tetonvalleynews.net\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.chicago2.vip.townnews.com\/tetonvalleynews.net\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22591864201/tetonvalleynews.net/freeaccess';
            
                gptAdSlots['ad-2210382'] = googletag.defineSlot(adUnit, [[2, 1], [1, 1]], 'ad-2210382').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-2210382'].setTargeting('pos', ['impact-top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22591864201/tetonvalleynews.net/freeaccess';
            
                gptAdSlots['ad-2210385'] = googletag.defineSlot(adUnit, [1, 1], 'ad-2210385').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-2210385'].setTargeting('pos', ['impact-sticky-anchor']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22591864201/tetonvalleynews.net/freeaccess';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320, 50]).addSize([768, 0], [[728, 90], [320,50]]).addSize([992, 0], [[970, 90], [728, 90], [970, 250]]).addSize([1200, 0], [[1170, 90], [970, 90], [728, 90], [970, 250]]).build();
                gptAdSlots['ad-2210367'] = googletag.defineSlot(adUnit, [[320,50],[728,90],[970,90],[970,250],[1170,90]], 'ad-2210367').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-2210367'].setTargeting('pos', ['breakout-one']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.283bfb49ef55c073fceda15ffbf58de8.js"></script>
<script async="async" src="https://app.worldtable.co/the-world-table.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/search/resources/scripts/tnt.followed.notifications.6600e99595fd219e961e9882c796e61c.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22591864201/tetonvalleynews.net/freeaccess';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[300, 250], [320, 50]]).addSize([768, 0], [[300, 250], [320, 50]]).addSize([992, 0], [[300, 250], [300,600]]).addSize([1200, 0], [[300, 250], [300,600]]).build();
                gptAdSlots['ad-2210370'] = googletag.defineSlot(adUnit, [[300,250],[320,50],[300,600]], 'ad-2210370').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-2210370'].setTargeting('pos', ['rectangle-one']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22591864201/tetonvalleynews.net/freeaccess';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[300,250], [320,50]] ).addSize([768, 0], [[300,250], [320,50]] ).addSize([992, 0], [[300, 250], [300,600]]).addSize([1200, 0], [[300, 250], [300,600]]).build();
                gptAdSlots['ad-2210373'] = googletag.defineSlot(adUnit, [[300,250],[320,50],[300,600]], 'ad-2210373').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-2210373'].setTargeting('pos', ['rectangle-two']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22591864201/tetonvalleynews.net/freeaccess';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[300,250], [320,50]] ).addSize([768, 0], [[300,250], [320,50]] ).addSize([992, 0], [[300, 250], [300,600]]).addSize([1200, 0], [[300, 250], [300,600]]).build();
                gptAdSlots['ad-2210376'] = googletag.defineSlot(adUnit, [[300,250],[320,50],[300,600]], 'ad-2210376').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-2210376'].setTargeting('pos', ['rectangle-three']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22591864201/tetonvalleynews.net/freeaccess';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[300,600], [300, 250]]).addSize([1200, 0], [[300,600], [300, 250]]).build();
                gptAdSlots['ad-2210388'] = googletag.defineSlot(adUnit, [[300,600],[300,250]], 'ad-2210388').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-2210388'].setTargeting('pos', ['sticky-side-rail']);
    });
 /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.pop();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }
            googletag.pubads().disableInitialLoad();
            googletag.pubads().addEventListener('impressionViewable', function(event) {
                for (var key in gptAdSlots) {
                    if (gptAdSlots[key] === event.slot && __tnt.ads.slots[key]) {
                        if (!__tnt.ads.slots[key].viewableImpression) __tnt.ads.slots[key].viewableImpression = true;
                    }
                }
            });

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Victor teen donates 400 Covid tests to community | Freeaccess | tetonvalleynews.net</title>
            
    <style>body { background-color: #FFF; color: #222; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #000; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #FFF; } .tnt-content-width-container > * { max-width: 1366px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #343434; } .fixed-nav #main-navigation { background-color: #343434 !important; } #site-top-nav-container, #site-top-nav { background-color: #ffffff; } #site-footer-container, #site-footer { background-color: #222222; color: #EFEFEF; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #FFF; } .navbar-toggle .icon-bar { background-color: #FFF !important; } .navbar-toggle .sr-only-show { color: #FFF !important; } #site-top-nav .list-inline>li>a { color: #222; } .asset .asset-body p, .asset #asset-content p { color: #222; }@media (min-width: 1200px) { .container { width: 100%; } } @media (min-width: 1396px) { .container.has-wallpaper, .has-wallpaper .container, .container { width: 1366px; } } #site-header-container { background-color: #ffffff; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-bottom-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #FFF; } }#site-copyright a, #site-footer a { color: #EFEFEF; }.search-redesign .top-breakout > .row { max-width: 1366px; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #27537a; }#site-header-container{ border-bottom: 3px solid #27537a; }#site-footer-container{ border-top: 3px solid #27537a; } .tnt-bg-accent { background-color: #27537a; } a .tnt-caret-down { color: #27537a; } .block-title .block-title-inner { border-color: #27537a; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #27537a; } .form-control:focus { border-bottom-color: #27537a; }</style> <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.tetonvalleynews.net/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/df67cbfe-1b1c-11e7-b892-3343057f8ea2.png?resize=180%2C180" />
    
        <link rel="amphtml" href="https://www.tetonvalleynews.net/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.amp.html" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//app.worldtable.co">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="Victor teen donates 400 Covid tests to community | Freeaccess | tetonvalleynews.net" href="http://www.tetonvalleynews.net/search/?f=rss&amp;t=article&amp;c=freeaccess&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.tetonvalleynews.net/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" />
            <script defer src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.3aa64d478db9cdd63e9d4b159e0c9334.js"></script>
            <script type="text/javascript" src="http://s.ntv.io/serve/load.js"></script>

        </head>
        <body class="fixed-scroll-nav app-editorial grid-centerpiece blox-asset uuid-1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a  section-freeaccess type-article infinity-disabled" data-authors='["jtellman@tetonvalleynews.net"]' data-path="/freeaccess">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.tetonvalleynews.net'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.61.0&amp;townnews.crm.group_id=287&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=centerpiece&amp;tncms.page.style=default&amp;tncms.page.path=%2Ffreeaccess&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=true&amp;tncms.asset.author=Julia+Tellman&amp;tncms.asset.start_hour=09&amp;tncms.asset.id=1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Ffreeaccess%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html&amp;tncms.vendor.outbrain=disabled&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=248&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PFQH52B&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.61.0&amp;townnews.crm.group_id=287&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=centerpiece&amp;tncms.page.style=default&amp;tncms.page.path=%2Ffreeaccess&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=true&amp;tncms.asset.author=Julia+Tellman&amp;tncms.asset.start_hour=09&amp;tncms.asset.id=1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Ffreeaccess%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html&amp;tncms.vendor.outbrain=disabled&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=248&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <a href="#main-page-container" class="sr-only" onclick="document.getElementById('main-page-container').scrollIntoView(); return false">Skip to main content</a><div id="fb-root"></div>
        
        
        
        <div id="access-offers-modal"  class=" access-offers-wrapper access-modal access-offers-modal">
        <div class="modal fade" data-backdrop="static" data-keyboard="false">
            <div class="modal-dialog offer-tab">
                <!-- OFFERS TAB -->
                <div id="modal-offers-tab" class="modal-content primary-tab hide" data-active-class="offer-tab">
                    <div class="modal-header">
                        <button type="button" class="close" data-dismiss="modal" aria-label="Close">
                            <span aria-hidden="true">&times;</span>
                        </button>   
                        <h3 class="offer-group-title text-center"></h3>
                    </div>
                    <div class="modal-body">

                        <template class="template promo-error-template">
                            <div class="promo-error alert alert-warning">
    <p><strong>Sorry</strong>, an error occurred.</p>
</div></template><template class="template-promo-service hide">
                            <div class="promotion-service subscription-service panel panel-default">
                                <h4 class="method-featured"></h4>
                                <h3 class="method-header"></h3>
                                <div class="method-image"></div>
                                <div class="offer-details">
                                    <p class="offer-rate"></p>
                                    <p class="offer-limits"></p>
                                    <p class="offer-cycle"></p>
                                    <p class="offer-savings"></p>
                                    <p class="offer-cancel"></p>
                                </div>

                                <div class="method-footer">
                                    <a data-subscription-service="" class="method-link btn btn-primary btn-lg">Get Started</a>
                                </div>

                            </div>
                        </template>

                        <div id="access-modal-description" class="text-center"></div>
                        <div class="access-login col-sm-8 col-sm-push-2"><div class="not-logged-in">
                                <div id="offers-modal-user-links" class="padding-bottom text-center">
    <a class="btn btn-primary btn-lg" href="https://www.tetonvalleynews.net/users/login/?referer_url=https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html">Log In</a>
    <a id="access-registration" class="btn btn-default btn-lg" href="https://apg05.newzware.com/ss70v2/adams/common/template.jsp?skin=tvn&nwmodule=sso&init=nonsub&nwpage=sso&rpage=https%3A%2F%2Fwww.tetonvalleynews.net%2Ftncms%2Fauth%2Fbegin%2F%3Fprovider%3DNewzware%26return%3Dhttps%253A%252F%252Fwww.tetonvalleynews.net%252Ffreeaccess%252Fvictor-teen-donates-400-covid-tests-to-community%252Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html">Sign Up</a></div>
                            </div>
                            
                            
    <div class="logged-in alert alert-success row" role="alert">
        <div class="col-sm-8 text-left">You are logged in <strong class="tn-user-screenname"></strong></div>
        <div class="col-sm-4 text-right">&nbsp;<a class="alert-link" href="https://www.tetonvalleynews.net/users/login/?referer_url=https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html">Switch accounts</a></div>
    </div>

                        </div>
                        <div class="clearfix"></div>
                        
                        <h2 class="promo-loading text-center font-larger" style="display:none;"><span class="fas tnt-spinner tnt-spin"></span></h2><div id="access-methods" class="output access-methods-list" data-referer="https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html">
                            Offers go here
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>                
            
                <!-- SIGNUP TAB -->
                <div id="user-modal-tab-signup" class="modal-content hide" >
                    <div class="modal-header">
                        <button type="button" class="tab-back btn btn-sm btn-default" aria-label="Previous Tab">
                            <span>Back</span>
                        </button>
                    
                        <button type="button" class="close" data-dismiss="modal" aria-label="Close">
                            <span aria-hidden="true">&times;</span>
                        </button>
                        
                        <h3 class="text-center">Sign Up</h3>
                    </div>
                    <div class="modal-body"><div class="user-register-blox">

                <form id="user-register-form" class="user-login-form" role="form" method="post" action="https://apg05.newzware.com/ss70v2/adams/common/template.jsp?skin=tvn&nwmodule=sso&init=nonsub&nwpage=sso&rpage=https%3A%2F%2Fwww.tetonvalleynews.net%2Ftncms%2Fauth%2Fbegin%2F%3Fprovider%3DNewzware%26return%3Dhttps%253A%252F%252Fwww.tetonvalleynews.net%252Ffreeaccess%252Fvictor-teen-donates-400-covid-tests-to-community%252Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"><input name="referer_url" type="hidden" value="/"><fieldset><div class="form-group">
                                <label for="input-username" class="control-label hide">
                                    <span class="text-danger">*</span> Username
                                </label>
                                <div class="input-container">
                                    <input id="input-username" class="form-control" type="text" name="screen_name" value="" data-check-url="https://www.tetonvalleynews.net/users/check/" placeholder="Username (Optional)" data-toggle="tooltip" data-placement="top" title=" This is the name that will be displayed next to your photo for comments, blog posts, and more. Choose wisely!">
                                    <span class="sr-only"> This is the name that will be displayed next to your photo for comments, blog posts, and more. Choose wisely!</span>
                                </div>
                            </div><div class="form-group">
                            <label for="input-email" class="control-label hide"><span class="text-danger">*</span> Email</label>
                            <div class="input-container">
                                <input id="input-email" class="form-control" type="email" name="email" value="" placeholder="Email" data-toggle="tooltip" data-placement="top" title="Your e-mail address will be used to confirm your account. We won't share it with anyone else." required>
                                <span class="sr-only">Your e-mail address will be used to confirm your account. We won't share it with anyone else.</span>
                            </div>
                        </div>

                        <div class="form-group">
                                <label for="input-password" class="control-label hide"><span class="text-danger">*</span> Password</label>
                                <div class="input-container">
                                    <input id="input-password" class="form-control" type="password" name="password" autocomplete="off" placeholder="Password" data-toggle="tooltip" data-placement="top" title="Create a password that only you will remember. If you forget it, you'll be able to recover it using your email address." required>
                                    <span class="sr-only">Create a password that only you will remember. If you forget it, you'll be able to recover it using your email address.</span>
                                </div>
                            </div>

                            <div class="form-group">
                                <label for="input-confirm-password" class="control-label hide"><span class="text-danger">*</span> Confirm Password</label>
                                <div class="input-container">
                                    <input id="input-confirm-password" class="form-control" type="password" name="password_verify" autocomplete="off" placeholder="Confirm Password" data-toggle="tooltip" data-placement="top" title="Confirm your password." required>
                                    <span class="sr-only">Confirm your password.</span>
                                </div>
                            </div></fieldset>

                    

                    

                    
                        <fieldset>
                            <div class="form-group">
                                <label for="tncms_captcha_response" class="sr-only">CAPTCHA</label>
                                <div class="input-container text-center">
                                    <div id="tn-vk-modal-signup" class="tn-vk-container"></div>
                                </div>
                            </div>
                        </fieldset><fieldset>
                        <div class="user-register-submit form-group">
                            <div class="input-container text-center">
                                <button type="submit" class="btn btn-lg btn-primary">Create Account</button>
                            </div>
                        </div>
                    </fieldset></form><div class="user-login-or-container">
                                <span class="user-login-or text-muted">OR</span>
                            </div>
                            <p class="text-center">Sign up with</p><div class="user-login-fed-auth">
    <form role="form" method="post" action="https://www.tetonvalleynews.net/users/login/"><input type="hidden" name="referer_url" value="https://www.tetonvalleynews.net/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"><button type="submit" name="username" value="provider:Newzware" class="btn btn-block btn-lg btn-Newzware">
                <span class="far tnt-circle"></span> Newzware</button></form>
</div></div>
    <script>
        window.tntSignup = document.createEvent('Event');
        tntSignup.initEvent('tnt-signup',true,true,{});
    
        var signupVkSetup = false,
            signupVkLoad = false,
            signupVkCallback = function() {
                signupVkLoad = true;
            };
        
        jQuery(document).ready(function($){
            $('#user-register-form input').each(function(){
                if( $(this).attr('data-mask') && $(this).data('mask') !== '' ){
                    $(this).mask( $(this).data('mask') );
                }
            });
    
            if( $('#input-smslist-phone').length > 0 && $('#input-phone').length > 0 ){
                $('#input-phone').change(function(){
                    $('#input-smslist-phone').val( $(this).val() );
                });
            }

            document.getElementById('user-register-form').addEventListener('click', function(e) {
                if (e.target.matches('.mailing-lists-select-all')) {
                    var inputs = document.getElementById('user-register-form')['lists[]'];
                    for (var i=0; i<inputs.length; i++) {
                        inputs[i].checked = true;
                    }
                } else if (e.target.matches('.mailing-lists-select-none')) {
                    var inputs = document.getElementById('user-register-form')['lists[]'];
                    for (var i=0; i<inputs.length; i++) {
                        inputs[i].checked = false;
                    }
                }
            });
            
            $('#user-register-form').validate({
                onkeyup: false,
                errorPlacement: function(error, element){
                    error.appendTo( element.parents('.form-group').find('.input-container') );
                },
                errorClass: 'has-error text-danger',
                validClass: 'has-success text-success',
                highlight: function(element, errorClass, validClass){
                    $(element).parents('.form-group').addClass(errorClass).removeClass(validClass);
                },
                unhighlight: function(element, errorClass, validClass){
                    $(element).parents('.form-group').removeClass(errorClass).addClass(validClass);
                },
                rules: {
                    phone: {
                        required: function(element){
                            return $('input[name="smslist_lists[]"]').is(':checked');
                        }
                    },
                    screen_name: {
                        required: true,
                        remote_username: __tnt.scrubUrl($('#input-username').data('check-url'))
                    },
                    
                    password_verify: {
                        equalTo: '#input-password'
                    }
                },
                messages: {
                    
                    password_verify: {
                        equalTo: "The password you entered doesn't match."
                    }
                }, submitHandler: function(form) {
                        $('#user-register-form button').prop('disabled', true);//form.submit();
                    }});
    
            $.validator.addMethod("first_last_names", function(value, element) {
                return this.optional( element ) || /^[a-z][- '.,a-z]+$/i.test( value );
            }, 'Names must start with a letter and can only contain valid characters.');
        });
    </script></div>
                    <div class="modal-footer">
                        <div class="text-right padding-bottom">
                            <a href="javascript:void(0)" class="active" id="user-modal-login-toggle">Have an account? Log In</a>
                        </div>
                    </div>
                </div>

                <!-- SIGNUP SUCCESS VERIFICATION -->
                <div id="user-modal-tab-signup-success" class="modal-content hide">
                    <div class="modal-header">
                        <button type="button" class="close" data-dismiss="modal" aria-label="Close">
                            <span aria-hidden="true">&times;</span>
                        </button>
                        
                        <h3 class="text-center">You're all set!</h3>
                    </div>
                    <div class="modal-body row">

                        <div class="col-xs-12" id="user-modal-tabs">
                            <div id="user-modal-signup-success-tab">

                                <p id="user-modal-signup-success-check" class="text-center"><i class="fas tnt-check"></i></p>
                                
                                <p class="text-center"><strong>Thank you <span class="username"></span></strong>.</p>
                                <p class="text-center">Your account has been registered, and you are now logged in.</p>
                                <p class="text-center">Check your email for details.</p>
                                
                            </div>
                        </div>
                    </div>
                    <div class="modal-footer text-center">
                        <a href="javascript:void(0)" class="btn btn-primary btn-lg" data-dismiss="modal" aria-label="OK">OK</a>
                    </div>
                </div>

                <!-- LOGIN TAB -->
                <div id="user-modal-tab-login" class="modal-content active">
                    <div class="modal-header">
                        <button type="button" class="tab-back btn btn-sm btn-default" aria-label="Previous Tab">
                            <span>Back</span>
                        </button>
                    
                        <button type="button" class="close" data-dismiss="modal" aria-label="Close">
                            <span aria-hidden="true">&times;</span>
                        </button>
                
                        <h3 id="user-modal-login-heading" class="text-center">Log In</h3>
                    </div>
                    <div class="modal-body row">

                        <div class="col-xs-12" id="user-modal-tabs">
                            <div id="user-modal-login-tab" class=""><div class="user-login-blox"><form id="access-modal-login-form" class="user-login-form" role="form" method="post" action="https://www.tetonvalleynews.net/users/login/">
                <div class="alert alert-danger critical-error hide">
                    <p>Invalid password or account does not exist</p>
                </div><input type="hidden" name="referer_url" value="https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"><div class="user-login-username form-group">
                    <label for="user-username" class="control-label hide">Email</label>
                    <div class="input-container">
                        <input id="user-username" class="form-control" name="username" type="text" value="" placeholder="Email Address" required>
                    </div>
                </div>
                
                <div class="user-login-password form-group">
                    <label for="user-password" class="control-label hide">Password</label><div class="input-group">
        <input id="user-password" class="form-control" name="password" type="password" autocomplete="off" required  placeholder="Password">
        <div id="user-password-toggle" class="input-group-addon password-toggle" title="Toggle password visibility">
            <i class="fas tnt-eye"></i>
        </div>
    </div></div>
                
                <div class="user-login-remember form-group row">
                    <div class="input-container col-xs-6">
                        <div class="checkbox">
                            <label>
                                <input name="remember_me" type="checkbox" value="1"> Remember me
                            </label>
                        </div>
                    
                    </div>
                    <div class="col-xs-6 text-right forgot-wrapper">
                        <a id="open-modal-forgot" class="" href="https://www.tetonvalleynews.net/users/forgot/?referer_url=https%253A%252F%252Fwww.tetonvalleynews.net%252Ffreeaccess%252Fvictor-teen-donates-400-covid-tests-to-community%252Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html">
                           Forgot your password?
                        </a>
                    </div>
                </div>
                
                <div class="user-login-submit form-group">
                    <div class="input-container text-center">
                        <button type="submit" class="btn btn-lg btn-primary">Log In</button>
                    </div>
                </div>
                
                <div class="text-center form-group">
                    <a id="open-modal-instant-login" class="btn btn-sm btn-default btn-instant-login" href="https://www.tetonvalleynews.net/users/instant-login/?referer_url=https%253A%252F%252Fwww.tetonvalleynews.net%252Ffreeaccess%252Fvictor-teen-donates-400-covid-tests-to-community%252Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html">
                        Email me a log in link
                    </a>
                </div>

                
            </form><div class="user-login-or-container">
                        <span class="user-login-or text-muted">OR</span>
                    </div>
                    <p class="text-center">Sign in with</p><div class="user-login-fed-auth">
    <form role="form" method="post" action="https://www.tetonvalleynews.net/users/login/"><input type="hidden" name="referer_url" value="https://www.tetonvalleynews.net/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"><button type="submit" name="username" value="provider:Newzware" class="btn btn-block btn-lg btn-Newzware">
                <span class="far tnt-circle"></span> Newzware</button></form>
</div></div></div>

                        </div>
                    </div>
                    <div class="modal-footer">
                        <div class="text-right padding-bottom">
                            <a href="javascript:void(0)" class="" id="user-modal-signup-toggle">Need an account? Sign Up</a>
                        </div>
                    </div>
                </div>
                
                <!-- FORGOT TAB -->
                <div id="user-modal-tab-forgot" class="modal-content hide">
                    <div class="modal-header">
                        <button type="button" class="tab-back btn btn-sm-default" aria-label="Previous Tab">
                            <span>Back</span>
                        </button>
                        
                        <button type="button" class="close" data-dismiss="modal" aria-label="Close">
                            <span aria-hidden="true">&times;</span>
                        </button>
                        
                        <h3 class="text-center">Reset password</h3>
                    </div>
                    
                    <div class="modal-body row">
                        <div class="col-xs-12">
                        <p class="">Submitting this form below will send a message to your email with a link to change your password.</p>

    <form id="user-modal-forgot-form" class="form-horizontal" role="form" method="post" action="https://www.tetonvalleynews.net/users/forgot/">
        <input type="hidden" name="referer_url" value="https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html">
        <div class="user-login-username form-group">
            <label for="user-username" class="sr-only">Username</label>
            <div class="col-xs-12">
                <input id="forgot-username" class="form-control" name="username" type="text" placeholder="Email or Screen Name" value="" required>
            </div>
        </div>
        
            <fieldset>
                <div class="form-group">
                    <label for="tncms_captcha_response" class="sr-only">CAPTCHA</label>
                    <div class="input-container text-center">
                        <div id="tn-vk-modal-forgot" class="tn-vk-container"></div>
                    </div>
                </div>
            </fieldset><div class="user-login-submit form-group">
            <div class="text-center">
                <button type="submit" class="btn btn-primary">Reset Password</button> 
            </div>
        </div>
        
    </form></div>
                    </div>
                </div>
                
                <div id="user-modal-tab-forgot-success" class="modal-content hide">
                    <div class="modal-header">
                        <button type="button" class="close" data-dismiss="modal" aria-label="Close">
                            <span aria-hidden="true">&times;</span>
                        </button>
                        
                        <h3 class="text-center">Forgot Password</h3>
                    </div>
                    
                    <div class="modal-body">
                        <p>An email message containing instructions on how to reset your password has been sent to the e-mail address listed on your account.</p>
                    </div>
                
                </div>
                
                <!-- INSTANT LOG-IN TAB -->
                <div id="user-modal-tab-instant-login" class="modal-content hide">
                    <div class="modal-header">
                        <button type="button" class="tab-back btn btn-sm-default" aria-label="Previous Tab">
                            <span>Back</span>
                        </button>
                        
                        <button type="button" class="close" data-dismiss="modal" aria-label="Close">
                            <span aria-hidden="true">&times;</span>
                        </button>
                        
                        <h3 class="text-center">Email me a log in link</h3>
                    </div>
                    
                    <div class="modal-body row">
                        <div class="col-xs-12">
                        <form class="form-horizontal" role="form" method="post" action="https://www.tetonvalleynews.net/users/instant-login/">
    <div class="form-group">
        <div class="col-xs-12">
            <label for="instant-login-email" class="sr-only">Account email</label>
            <input id="instant-login-email" class="form-control" name="email" type="email" value="" required placeholder="Account email">
        </div>
    </div>
    <div class="form-group">
       <label for="tncms_captcha_response" class="sr-only">CAPTCHA</label>
        <div class="input-container text-center">
            <div id="tn-vk-modal-instant-login" class="tn-vk-container"></div>
        </div>
    </div>
    <div class="user-login-link-submit form-group">
        <div class="text-center">
            <button type="submit" class="btn btn-primary">Send email</button> 
        </div>
    </div>
</form></div>
                    </div>
                </div>

                <!-- PURCHASE TAB -->
                <div id="user-modal-tab-purchase" class="modal-content hide">
                    <div class="modal-header">
                        <button type="button" class="tab-back btn btn-sm btn-default" aria-label="Previous Tab">
                            <span>Back</span>
                        </button>
                    
                        <button type="button" class="close" data-dismiss="modal" aria-label="Close">
                            <span aria-hidden="true">&times;</span>
                        </button>
                
                        <h3 class="text-center">Purchase Access</h3>
                    </div>
                    
                    <div class="modal-body row">
                        <div class="col-xs-12 purchase-form-wrapper"><div id="user-purchase-wrapper" class="col-xs-12">
        
        <div id="user-purchase-rate">
            <template>
                <div data-service-id="" data-rate-id="">
                    <div class="service-rate">
                        <div class="row">
                            <div class="rate-info alert alert-info col-xs-12">
                                <div class="service-basics">
                                    <h4 class="rate-name"></h4>
                                    <p class="rate-price"></p>
                                </div>
                                <div class="service-details hide">
                                    <p class="service-description"></p>
                                    <a class="service-link" href="">See More Offers</a>
                                </div>
                                <div class="rate-info-expander">
                                    <span class="collapsed">details</span>
                                    <span class="expanded hide">close</span>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </template>
            <div class="subscribe-form-purchase-rate output"></div>
        </div>
        
        
    <div class="row">
        <div class="alert alert-warning alert-dismissible fade" role="alert" id="form-error-super-purchase" hidden>
            <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
            <div class="error-message"></div>
        </div>
    </div>

    <form id="form-super-purchase" class="form-horizontal" role="form" action="/tncms/subscription/buy/" method="post" onSubmit="submitPaymentFormSpreedly(); return false">
        <input type="hidden" name="referrer_url" value="/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" />
        <input type="hidden" name="service_id" value="" />
        <input type="hidden" name="rate_name" value="" />
        <input type="hidden" name="rate_id" value="" />
        <input type="hidden" name="rate_price" value="" />
        <input type="hidden" name="tnpay-token" id="tnpay-token-super-purchase">

        
            
    <div class="logged-in alert alert-success row" role="alert">
        <div class="col-sm-8 text-left">You are logged in <strong class="tn-user-screenname"></strong></div>
        <div class="col-sm-4 text-right">&nbsp;<a class="alert-link" href="https://www.tetonvalleynews.net/users/login/?referer_url=https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html">Switch accounts</a></div>
    </div>

            
            <p class="secure-notice text-center"><span class="fas tnt-lock tnt-fw"></span> Secure &amp; Encrypted</p>
            
            <fieldset id="form-signup-super-purchase" class="col-xs-12 not-logged-in">
                <legend>What's your e-mail address?</legend>
                <div class="form-group">
                    <label for="email" class="control-label sr-only">E-mail</label>
                    <input type="email" name="email" class="form-control" placeholder="E-mail" required />
                </div>
                <div class="form-group">
                    <div class="row">
                        <div class="col-xs-6">
                            <label for="password" class="sr-only">Password</label>
                            <input type="password" name="password" class="form-control" placeholder="Password" required />
                        </div>
                        <div class="col-xs-6">
                            <label for="password_verify" class="sr-only">Confirm</label>
                            <input type="password" name="password_verify" class="form-control" placeholder="Confirm password" />
                        </div>
                    </div>
                </div>
            </fieldset>
        
      

        <fieldset id="form-location-super-purchase" class="col-xs-12 delivery-location-required" hidden>
            <legend>What's your delivery address?</legend>
            <div class="form-group">
                <label for="address" class="control-label sr-only">Address</label>
                <input type="text" name="address" class="form-control" placeholder="Address" />
            </div>

            <div class="form-group">
                <label for="municipality" class="control-label sr-only">City</label>
                <input type="text" name="municipality" class="form-control" placeholder="City" />
            </div>

            <div class="form-group">
                <div class="row">
                    <div class="col-xs-7 col-md-4">
                        <label class="control-label sr-only" for="region">State</label>
                        <select class="form-control" name="region" placeholder="State"><option value="AL" >Alabama</option><option value="AK" >Alaska</option><option value="AZ" >Arizona</option><option value="AR" >Arkansas</option><option value="CA" >California</option><option value="CO" >Colorado</option><option value="CT" >Connecticut</option><option value="DE" >Delaware</option><option value="FL" >Florida</option><option value="GA" >Georgia</option><option value="HI" >Hawaii</option><option value="ID" selected>Idaho</option><option value="IL" >Illinois</option><option value="IN" >Indiana</option><option value="IA" >Iowa</option><option value="KS" >Kansas</option><option value="KY" >Kentucky</option><option value="LA" >Louisiana</option><option value="ME" >Maine</option><option value="MD" >Maryland</option><option value="MA" >Massachusetts</option><option value="MI" >Michigan</option><option value="MN" >Minnesota</option><option value="MS" >Mississippi</option><option value="MO" >Missouri</option><option value="MT" >Montana</option><option value="NE" >Nebraska</option><option value="NV" >Nevada</option><option value="NH" >New Hampshire</option><option value="NJ" >New Jersey</option><option value="NM" >New Mexico</option><option value="NY" >New York</option><option value="NC" >North Carolina</option><option value="ND" >North Dakota</option><option value="OH" >Ohio</option><option value="OK" >Oklahoma</option><option value="OR" >Oregon</option><option value="PA" >Pennsylvania</option><option value="RI" >Rhode Island</option><option value="SC" >South Carolina</option><option value="SD" >South Dakota</option><option value="TN" >Tennessee</option><option value="TX" >Texas</option><option value="UT" >Utah</option><option value="VT" >Vermont</option><option value="VA" >Virginia</option><option value="WA" >Washington</option><option value="DC" >Washington D.C.</option><option value="WV" >West Virginia</option><option value="WI" >Wisconsin</option><option value="WY" >Wyoming</option><option value="PR" >Puerto Rico</option><option value="VI" >US Virgin Islands</option><option value="AA" >Armed Forces Americas</option><option value="AP" >Armed Forces Pacific</option><option value="AE" >Armed Forces Europe</option><option value="MP" >Northern Mariana Islands</option><option value="MH" >Marshall Islands</option><option value="AS" >American Samoa</option><option value="FM" >Federated States of Micronesia</option><option value="GU" >Guam</option><option value="PW" >Palau</option><option value="AB" >Alberta, Canada</option><option value="BC" >British Columbia, Canada</option><option value="MB" >Manitoba, Canada</option><option value="NB" >New Brunswick, Canada</option><option value="NL" >Newfoundland, Canada</option><option value="NS" >Nova Scotia, Canada</option><option value="NT" >Northwest Territories, Canada</option><option value="NU" >Nunavut, Canada</option><option value="ON" >Ontario, Canada</option><option value="PE" >Prince Edward Island, Canada</option><option value="QC" >Quebec, Canada</option><option value="SK" >Saskatchewan, Canada</option><option value="YT" >Yukon Territory, Canada</option></select>
                    </div>
                    <div class="col-xs-5 col-md-3">
                        <label for="postal_code" class="control-label sr-only">Zip Code</label>
                        <input type="text" name="postal_code" class="form-control" placeholder="Zip Code"/>
                    </div>
                </div>
            </div>
            
            <div class="form-group">
                <div class="row">
                    <div class="col-xs-7">
                        <label for="country" class="control-label sr-only">Country</label>
                        <div class="input-container">
                            <select id="select-country-super-purchase" name="country" class="form-control"><option value="US" selected>United States of America</option><option value="VI" >US Virgin Islands</option><option value="UM" >United States Minor Outlying Islands</option><option value="CA" >Canada</option><option value="MX" >Mexico, United Mexican States</option><option value="BS" >Bahamas, Commonwealth of the</option><option value="CU" >Cuba, Republic of</option><option value="DO" >Dominican Republic</option><option value="HT" >Haiti, Republic of</option><option value="JM" >Jamaica</option><option value="AF" >Afghanistan</option><option value="AL" >Albania, People's Socialist Republic of</option><option value="DZ" >Algeria, People's Democratic Republic of</option><option value="AS" >American Samoa</option><option value="AD" >Andorra, Principality of</option><option value="AO" >Angola, Republic of</option><option value="AI" >Anguilla</option><option value="AQ" >Antarctica (the territory South of 60 deg S)</option><option value="AG" >Antigua and Barbuda</option><option value="AR" >Argentina, Argentine Republic</option><option value="AM" >Armenia</option><option value="AW" >Aruba</option><option value="AU" >Australia, Commonwealth of</option><option value="AT" >Austria, Republic of</option><option value="AZ" >Azerbaijan, Republic of</option><option value="BH" >Bahrain, Kingdom of</option><option value="BD" >Bangladesh, People's Republic of</option><option value="BB" >Barbados</option><option value="BY" >Belarus</option><option value="BE" >Belgium, Kingdom of</option><option value="BZ" >Belize</option><option value="BJ" >Benin, People's Republic of</option><option value="BM" >Bermuda</option><option value="BT" >Bhutan, Kingdom of</option><option value="BO" >Bolivia, Republic of</option><option value="BA" >Bosnia and Herzegovina</option><option value="BW" >Botswana, Republic of</option><option value="BV" >Bouvet Island (Bouvetoya)</option><option value="BR" >Brazil, Federative Republic of</option><option value="IO" >British Indian Ocean Territory (Chagos Archipelago)</option><option value="VG" >British Virgin Islands</option><option value="BN" >Brunei Darussalam</option><option value="BG" >Bulgaria, People's Republic of</option><option value="BF" >Burkina Faso</option><option value="BI" >Burundi, Republic of</option><option value="KH" >Cambodia, Kingdom of</option><option value="CM" >Cameroon, United Republic of</option><option value="CV" >Cape Verde, Republic of</option><option value="KY" >Cayman Islands</option><option value="CF" >Central African Republic</option><option value="TD" >Chad, Republic of</option><option value="CL" >Chile, Republic of</option><option value="CN" >China, People's Republic of</option><option value="CX" >Christmas Island</option><option value="CC" >Cocos (Keeling) Islands</option><option value="CO" >Colombia, Republic of</option><option value="KM" >Comoros, Union of the</option><option value="CD" >Congo, Democratic Republic of</option><option value="CG" >Congo, People's Republic of</option><option value="CK" >Cook Islands</option><option value="CR" >Costa Rica, Republic of</option><option value="CI" >Cote D'Ivoire, Ivory Coast, Republic of the</option><option value="CY" >Cyprus, Republic of</option><option value="CZ" >Czech Republic</option><option value="DK" >Denmark, Kingdom of</option><option value="DJ" >Djibouti, Republic of</option><option value="DM" >Dominica, Commonwealth of</option><option value="EC" >Ecuador, Republic of</option><option value="EG" >Egypt, Arab Republic of</option><option value="SV" >El Salvador, Republic of</option><option value="GQ" >Equatorial Guinea, Republic of</option><option value="ER" >Eritrea</option><option value="EE" >Estonia</option><option value="ET" >Ethiopia</option><option value="FO" >Faeroe Islands</option><option value="FK" >Falkland Islands (Malvinas)</option><option value="FJ" >Fiji, Republic of the Fiji Islands</option><option value="FI" >Finland, Republic of</option><option value="FR" >France, French Republic</option><option value="GF" >French Guiana</option><option value="PF" >French Polynesia</option><option value="TF" >French Southern Territories</option><option value="GA" >Gabon, Gabonese Republic</option><option value="GM" >Gambia, Republic of the</option><option value="GE" >Georgia</option><option value="DE" >Germany</option><option value="GH" >Ghana, Republic of</option><option value="GI" >Gibraltar</option><option value="GR" >Greece, Hellenic Republic</option><option value="GL" >Greenland</option><option value="GD" >Grenada</option><option value="GP" >Guadaloupe</option><option value="GU" >Guam</option><option value="GT" >Guatemala, Republic of</option><option value="GN" >Guinea, Revolutionary
People's Rep'c of</option><option value="GW" >Guinea-Bissau, Republic of</option><option value="GY" >Guyana, Republic of</option><option value="HM" >Heard and McDonald Islands</option><option value="VA" >Holy See (Vatican City State)</option><option value="HN" >Honduras, Republic of</option><option value="HK" >Hong Kong, Special Administrative Region of China</option><option value="HR" >Hrvatska (Croatia)</option><option value="HU" >Hungary, Hungarian People's Republic</option><option value="IS" >Iceland, Republic of</option><option value="IN" >India, Republic of</option><option value="ID" >Indonesia, Republic of</option><option value="IR" >Iran, Islamic Republic of</option><option value="IQ" >Iraq, Republic of</option><option value="IE" >Ireland</option><option value="IL" >Israel, State of</option><option value="IT" >Italy, Italian Republic</option><option value="JP" >Japan</option><option value="JO" >Jordan, Hashemite Kingdom of</option><option value="KZ" >Kazakhstan, Republic of</option><option value="KE" >Kenya, Republic of</option><option value="KI" >Kiribati, Republic of</option><option value="KP" >Korea, Democratic People's Republic of</option><option value="KR" >Korea, Republic of</option><option value="KW" >Kuwait, State of</option><option value="KG" >Kyrgyz Republic</option><option value="LA" >Lao People's Democratic Republic</option><option value="LV" >Latvia</option><option value="LB" >Lebanon, Lebanese Republic</option><option value="LS" >Lesotho, Kingdom of</option><option value="LR" >Liberia, Republic of</option><option value="LY" >Libyan Arab Jamahiriya</option><option value="LI" >Liechtenstein, Principality of</option><option value="LT" >Lithuania</option><option value="LU" >Luxembourg, Grand Duchy of</option><option value="MO" >Macao, Special Administrative Region of China</option><option value="MK" >Macedonia, the former Yugoslav Republic of</option><option value="MG" >Madagascar, Republic of</option><option value="MW" >Malawi, Republic of</option><option value="MY" >Malaysia</option><option value="MV" >Maldives, Republic of</option><option value="ML" >Mali, Republic of</option><option value="MT" >Malta, Republic of</option><option value="MH" >Marshall Islands</option><option value="MQ" >Martinique</option><option value="MR" >Mauritania, Islamic Republic of</option><option value="MU" >Mauritius</option><option value="YT" >Mayotte</option><option value="FM" >Micronesia, Federated States of</option><option value="MD" >Moldova, Republic of</option><option value="MC" >Monaco, Principality of</option><option value="MN" >Mongolia, Mongolian People's Republic</option><option value="MS" >Montserrat</option><option value="MA" >Morocco, Kingdom of</option><option value="MZ" >Mozambique, People's Republic of</option><option value="MM" >Myanmar</option><option value="NA" >Namibia</option><option value="NR" >Nauru, Republic of</option><option value="NP" >Nepal, Kingdom of</option><option value="AN" >Netherlands Antilles</option><option value="NL" >Netherlands, Kingdom of the</option><option value="NC" >New Caledonia</option><option value="NZ" >New Zealand</option><option value="NI" >Nicaragua, Republic of</option><option value="NE" >Niger, Republic of the</option><option value="NG" >Nigeria, Federal Republic of</option><option value="NU" >Niue, Republic of</option><option value="NF" >Norfolk Island</option><option value="MP" >Northern Mariana Islands</option><option value="NO" >Norway, Kingdom of</option><option value="OM" >Oman, Sultanate of</option><option value="PK" >Pakistan, Islamic Republic of</option><option value="PW" >Palau</option><option value="PS" >Palestinian Territory, Occupied</option><option value="PA" >Panama, Republic of</option><option value="PG" >Papua New Guinea</option><option value="PY" >Paraguay, Republic of</option><option value="PE" >Peru, Republic of</option><option value="PH" >Philippines, Republic of the</option><option value="PN" >Pitcairn Island</option><option value="PL" >Poland, Polish People's Republic</option><option value="PT" >Portugal, Portuguese Republic</option><option value="PR" >Puerto Rico</option><option value="QA" >Qatar, State of</option><option value="RE" >Reunion</option><option value="RO" >Romania, Socialist Republic of</option><option value="RU" >Russian Federation</option><option value="RW" >Rwanda, Rwandese Republic</option><option value="WS" >Samoa, Independent State of</option><option value="SM" >San Marino, Republic of</option><option value="ST" >Sao Tome and Principe, Democratic Republic of</option><option value="SA" >Saudi Arabia, Kingdom of</option><option value="SN" >Senegal, Republic of</option><option value="CS" >Serbia and Montenegro</option><option value="SC" >Seychelles, Republic of</option><option value="SL" >Sierra Leone, Republic of</option><option value="SG" >Singapore, Republic of</option><option value="SK" >Slovakia (Slovak Republic)</option><option value="SI" >Slovenia</option><option value="SB" >Solomon Islands</option><option value="SO" >Somalia, Somali Republic</option><option value="ZA" >South Africa, Republic of</option><option value="GS" >South Georgia and the South Sandwich Islands</option><option value="ES" >Spain, Spanish State</option><option value="LK" >Sri Lanka, Democratic Socialist Republic of</option><option value="SH" >St. Helena</option><option value="KN" >St. Kitts and Nevis</option><option value="LC" >St. Lucia</option><option value="PM" >St. Pierre and Miquelon</option><option value="VC" >St. Vincent and the Grenadines</option><option value="SD" >Sudan, Democratic Republic of the</option><option value="SR" >Suriname, Republic of</option><option value="SJ" >Svalbard & Jan Mayen Islands</option><option value="SZ" >Swaziland, Kingdom of</option><option value="SE" >Sweden, Kingdom of</option><option value="CH" >Switzerland, Swiss Confederation</option><option value="SY" >Syrian Arab Republic</option><option value="TW" >Taiwan, Province of China</option><option value="TJ" >Tajikistan</option><option value="TZ" >Tanzania, United Republic of</option><option value="TH" >Thailand, Kingdom of</option><option value="TL" >Timor-Leste, Democratic Republic of</option><option value="TG" >Togo, Togolese Republic</option><option value="TK" >Tokelau (Tokelau Islands)</option><option value="TO" >Tonga, Kingdom of</option><option value="TT" >Trinidad and Tobago, Republic of</option><option value="TN" >Tunisia, Republic of</option><option value="TR" >Turkey, Republic of</option><option value="TM" >Turkmenistan</option><option value="TC" >Turks and Caicos Islands</option><option value="TV" >Tuvalu</option><option value="UG" >Uganda, Republic of</option><option value="UA" >Ukraine</option><option value="AE" >United Arab Emirates</option><option value="GB" >United Kingdom of Great Britain & N. Ireland</option><option value="UY" >Uruguay, Eastern Republic of</option><option value="UZ" >Uzbekistan</option><option value="VU" >Vanuatu</option><option value="VE" >Venezuela, Bolivarian Republic of</option><option value="VN" >Viet Nam, Socialist Republic of</option><option value="WF" >Wallis and Futuna Islands</option><option value="EH" >Western Sahara</option><option value="YE" >Yemen</option><option value="ZM" >Zambia, Republic of</option><option value="ZW" >Zimbabwe</option></select>
                        </div>
                    </div>
                    
                     <div class="col-xs-5">
                        <label for="phone" class="control-label sr-only">Phone</label>
                        <input type="tel" name="phone" class="form-control" placeholder="Phone number" />
                    </div>
                    
                </div>
            </div>
        </fieldset>

        <fieldset class="col-xs-12">
            <legend>How would you like to pay?</legend>

            <div class="form-group">
                <label for="tnpay-name" class="sr-only">Name</label>
                <input type="text" id="tnpay-name-super-purchase" class="form-control" name="tnpay-name" placeholder="Name on card" required>
            </div>

            <div class="form-group">
                <label class="sr-only">Credit Card</label>
                <div id="spreedly-number-super-purchase" class="form-control"></div>
            </div>

            <div class="form-group">
                <div class="col-xs-12 col-md-6">
                    <div class="form-group">
                        <div class="row">
                            <div class="col-xs-6">
                                <label>CVV</label>
                                <div id="spreedly-cvv-super-purchase" class="form-control"></div>
                            </div>
                            <div class="col-xs-6">
                                <label>Zip Code</label>
                                <input type="text" id="tnpay-zip-super-purchase" class="form-control" name="postal_code" placeholder="Zipcode" required>
                            </div>
                        </div>
                    </div>
                </div>
            
                <div class="col-xs-12 col-md-5 col-md-offset-1">
                    <div class="form-group">
                        <label class="control-label" for="tnpay-month">Expiration</label>
                        <div class="row">
                            <div class="col-xs-6">
                                <select id="tnpay-month-super-purchase" class="form-control" name="tnpay-month"><option value="1" >Jan</option><option value="2" selected>Feb</option><option value="3" >Mar</option><option value="4" >Apr</option><option value="5" >May</option><option value="6" >Jun</option><option value="7" >Jul</option><option value="8" >Aug</option><option value="9" >Sep</option><option value="10" >Oct</option><option value="11" >Nov</option><option value="12" >Dec</option></select>
                            </div>
                            <div class="col-xs-6">
                                <select id="tnpay-year-super-purchase" class="form-control" name="tnpay-year"><option value="2022" selected>2022</option><option value="2023" >2023</option><option value="2024" >2024</option><option value="2025" >2025</option><option value="2026" >2026</option><option value="2027" >2027</option><option value="2028" >2028</option><option value="2029" >2029</option><option value="2030" >2030</option><option value="2031" >2031</option><option value="2032" >2032</option></select>
                            </div>
                        </div>
                    </div>
                </div>
            </div>

            <div class="form-group tn-tos-group">
                <label><input id="tn-tos-super-purchase" type="checkbox" name="tos_confirm" /> <span class="tn-tos-agree">I Agree to the Subscription <a class="tos-link" href="">Terms of Use.</a></span><br/>
                <small class="service-renews" hidden>This service will be automatically renewed and your credit card billed once it nears expiration</small></label>
            </div>

            
            <div class="form-group text-center">
                <label for="tncms_captcha_response" class="sr-only">CAPTCHA</label>
                <div class="input-container">
                    <div id="tn-vk-super-purchase" class="tn-vk-container"></div>
                </div>
            </div></fieldset>

        <div class="form-group text-center">
            <input type="submit" class="btn btn-primary" id="form-submit-super-purchase" value="Pay Now" disabled>
        </div>

        <p class="secure-notice text-center">Secure transaction. Cancel anytime.</p>
    </form>

   
    </div>
    
</div>
                    </div>
                </div>
                
                <!-- PURCHASE SUCCESS -->
                <div id="user-modal-tab-purchase-success" class="modal-content hide">
                    <div class="modal-header">
                        <button type="button" class="close" data-dismiss="modal" aria-label="Close">
                            <span aria-hidden="true">&times;</span>
                        </button>
                        
                        <h3 class="text-center">You're all set!</h3>
                    </div>
                    <div class="modal-body row">

                        <div class="col-xs-12" id="user-modal-tabs">
                            <div id="user-modal-signup-success-tab">

                                <p class="purchase-success-checkmark text-center"><i class="fas tnt-check"></i></p>
                                
                                <p class="text-center"><strong>Thank you<span class="username"></span></strong>.</p>
                                <p class="text-center">Your purchase was successful, and you are now logged in.</p>
                                
                            </div>
                            
                            <div class="col-xs-12" id="modal-purchase-receipt">
                                <template>
                                    <h4 class="service-name"></h4>
                                    <div class="table-responsive">
                                        <table class="table">
                                            <tbody>
                                                <tr>
                                                    <td class="text-muted">Rate:</td>
                                                    <td class="service-rate"></td>
                                                </tr>
                                                <tr>
                                                    <td class="text-muted">Begins:</td><td class="service-start"></td>
                                                </tr>
                                                <tr>
                                                        <td class="text-muted">Ends:</td>
                                                        <td class="service-end"></td>
                                                    </tr>
                                                
                                                <tr>
                                                    <td class="text-muted">Transaction ID:</td>
                                                    <td class="transaction-id"></td>
                                                </tr>
                                            </tbody>
                                        </table>
                                    </div>
                                </template>
                            
                                <div class="modal-receipt-output"></div>
                            
                                <p class="text-center">A receipt was sent to your email.</p>
                            
                            </div>
                        </div>
                    </div>
                    <div class="modal-footer text-center">
                        <a href="javascript:void(0)" class="btn btn-danger btn-lg" data-dismiss="modal" aria-label="OK">OK</a>
                    </div>
                </div>
                
                <!-- SPINNER TAB -->
                <div id="modal-spinner-tab" class="modal-content hide">
                    <div class="modal-body row text-center">
                        <i class="fas tnt-spinner tnt-spin" style="font-size:64px;"></i>
                    </div>
                </div>

            </div>
        </div>
    </div><script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-contribute-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-certificate tnt-fw"></i></div>
                <div class="asset-edit-message">You are the owner of this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" href="https://www.tetonvalleynews.net/users/admin/contribute/article/?assetid=1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a&assettype=article"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit Article</a>
                    
                        <a class="btn btn-danger btn-sm" href="https://www.tetonvalleynews.net/users/admin/contribute/article/?from_section=/freeaccess"><i class="fas tnt-plus tnt-fw"></i> Add New Article</a>
                    
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.tetonvalleynews.net/tncms/admin/editorial-asset/?edit=1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left" aria-label="Left Main Menu" aria-expanded="false" tabindex="-1" >
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-2210271" class="tncms-block in-drawer"><div id="site-logo-2210271" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="/" aria-label="Home page"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/55cbf42a-6d64-11ec-a31e-476528d4778f.png?resize=200%2C69" 
            srcset="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/55cbf42a-6d64-11ec-a31e-476528d4778f.png?resize=150%2C51 150w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/55cbf42a-6d64-11ec-a31e-476528d4778f.png?resize=200%2C69 200w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/55cbf42a-6d64-11ec-a31e-476528d4778f.png?resize=225%2C77 225w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/55cbf42a-6d64-11ec-a31e-476528d4778f.png?resize=300%2C103 300w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/55cbf42a-6d64-11ec-a31e-476528d4778f.png 400w"
            sizes="100vw"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="400"
            height="137"
            alt="site-logo"
            ></a>
        </div></div></div><div id="tncms-block-2210268" class="tncms-block in-drawer social-links"><div class="follow-links-2210268 default">
    
    <section id="block-2210268" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="http://www.facebook.com/TetonValleyNews" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/tetonvalleynews/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.tetonvalleynews.net",
  "sameAs" : ["http://www.facebook.com/TetonValleyNews","https://twitter.com/tetonvalleynews/"]
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-2210274" class="tncms-block hidden-md hidden-lg"><section id="block-2210274" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-2210274" class="search-form-container card clearfix text-center hidden-print well">
    <form id="site-search-2210274" aria-labelledby="site-search-button-2210274" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal ">
        <input id="site-search-2210274-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-2210274-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span id="site-search-button-2210274" class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-2210274-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-2210274').submit();
        return false;
    });

    $('#site-search-2210274').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-2210274 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-2210274 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-2210274-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-2223078" class="tncms-block hidden-lg hidden-md in-drawer"><div id="user-controls-2223078" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://apg05.newzware.com/ss70v2/adams/common/template.jsp?skin=tvn&nwmodule=sso&init=nonsub&nwpage=sso&rpage=https%3A%2F%2Fwww.tetonvalleynews.net%2Ftncms%2Fauth%2Fbegin%2F%3Fprovider%3DNewzware%26return%3Dhttps%253A%252F%252Fwww.tetonvalleynews.net%252Ffreeaccess%252Fvictor-teen-donates-400-covid-tests-to-community%252Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.tetonvalleynews.net/users/login/?referer_url=https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.tetonvalleynews.net/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-2223078').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.tetonvalleynews.net/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.tetonvalleynews.net/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.tetonvalleynews.net/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-2223078').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.tetonvalleynews.net/users/logout/" id="user-logout-form-2223078"><input type="hidden" name="referer_url" value="https://www.tetonvalleynews.net/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-2223087" class="tncms-block hidden-lg hidden-md subpromo in-drawer"><section id="block-2223087" class="block emphasis-h3   " ><div id="promo-button-2223087" class="promo-button"><a href="/subscribe/"><button type="button" class="btn  btn-sm">SUBSCRIBE</button></a></div></section></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/covid19/"  class="nav-link tnt-section-covid-19">COVID-19</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/"  class="nav-link tnt-section-community">Community</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/housing/"  class="nav-link tnt-section-housing">Housing</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/education/"  class="nav-link tnt-section-education">Education</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/local_government/"  class="nav-link tnt-section-local-government">Local Government</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/sheriffs_log/"  class="nav-link tnt-section-sheriffs-log">Sheriff's Log</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/history/"  class="nav-link tnt-section-history">History</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/eedition/"  class="nav-link tnt-section-e-edition">e-Edition</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/"  class="nav-link tnt-section-all-sports">All Sports</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/ths/"  class="nav-link tnt-section-teton-high-school">Teton High School</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-5" data-target="#mobile-nav-left_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/letters_to_editor/"  class="nav-link tnt-section-letters-to-the-editor">Letters to the Editor</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/forms/letter_to_the_editor/"  class="nav-link tnt-section-submit-a-letter">Submit a Letter</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-6" data-target="#mobile-nav-left_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/local-events/"  class="nav-link tnt-section-calendar">Calendar</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=TETONVALLEYNEWS&amp;publisher_url:tetonvalleynews.net#/quick"  target="_blank" rel="noopener" class="nav-link tnt-section-promote-your-event">Promote Your Event</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/weather/"  class="nav-link tnt-section-weather">Weather</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-8" data-target="#mobile-nav-left_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/obituaries/"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/obituaries/place-an-obituary/"  class="nav-link tnt-section-submit-an-obituary">Submit an Obituary</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-9" data-target="#mobile-nav-left_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/contests/"  class="nav-link tnt-section-contests">Contests</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://tetonvalleynews.secondstreetapp.com/Best-of-Teton-Valley-2021-2/"  target="_blank" rel="noopener" class="nav-link tnt-section-best-of-teton-valley-2021">Best of Teton Valley 2021</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn"></div>
    
    
    
    
    <div id="tncms-region-global-skyline" class="tncms-region "><div id="tncms-block-2210382" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-2210382" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2210382');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-2210385" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-2210385" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2210385');
                        
                });
            </script>
        </div>
    </div>
</div></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list" ><li>
                <a class="nav-link   tnt-section-manage-your-subscription"  href="/managesubscription"  tabindex="0">
                    <span class="nav-label">Manage Your Subscription</span>
                </a></li><li>
                <a class="nav-link   tnt-section-idahojobsnow"  href="https://www.idahojobsnow.com"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">IdahoJobsNow</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-2209503" class="tncms-block apg-js-user-controls-dashboard"><div id="user-controls-2209503" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://apg05.newzware.com/ss70v2/adams/common/template.jsp?skin=tvn&nwmodule=sso&init=nonsub&nwpage=sso&rpage=https%3A%2F%2Fwww.tetonvalleynews.net%2Ftncms%2Fauth%2Fbegin%2F%3Fprovider%3DNewzware%26return%3Dhttps%253A%252F%252Fwww.tetonvalleynews.net%252Ffreeaccess%252Fvictor-teen-donates-400-covid-tests-to-community%252Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.tetonvalleynews.net/users/login/?referer_url=https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.tetonvalleynews.net/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-2209503').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.tetonvalleynews.net/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.tetonvalleynews.net/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.tetonvalleynews.net/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-2209503').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.tetonvalleynews.net/users/logout/" id="user-logout-form-2209503"><input type="hidden" name="referer_url" value="https://www.tetonvalleynews.net/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-2209506" class="tncms-block"><script>
let selector = ".apg-js-user-controls-dashboard .logged-in .dropdown .dropdown-menu li";
let dashBoardLink = document.querySelectorAll(selector)[1];
dashBoardLink.querySelector('a').href = "https://apg05.newzware.com/ss70v2/adams/common/template.jsp?autoLogout=N&nwmodule=main&nwpage=main";

selector = ".apg-js-user-controls-dashboard-mobile .logged-in .list-inline li"
dashBoardLink = document.querySelectorAll(selector)[0];
dashBoardLink.querySelector('a').href = "https://apg05.newzware.com/ss70v2/adams/common/template.jsp?autoLogout=N&nwmodule=main&nwpage=main";

</script></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-2223090" class="tncms-block eedition-latest"><section id="block-2223090" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-2223090 ">
        <div class="block-title-inner">
            <h4>
                
                Latest E-Edition
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-sm">
        
                
                <article id="card-summary-2223090-b9f3a894-31be-51a5-bf12-ac65bd14a5e9" class="tnt-asset-type-edition clearfix card summary has-image image-left inherit letterbox-style-blur  tnt-section-eedition">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-b9f3a894-31be-51a5-bf12-ac65bd14a5e9 media-preview edition-asset " data-aspect="original"><figure class="photo layout-vertical letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/eedition/teton-valley-news/edition_b9f3a894-31be-51a5-bf12-ac65bd14a5e9.html" class="tnt-asset-link"  aria-label="Teton Valley News">
                
                
                
                
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Teton Valley News"
                    class="img-responsive lazyload  letterbox blur"
                    width="300"
                    height="618"
                    data-src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/eedition/4/db/4db8acee-36dd-556b-8647-a9229b6b8bed/61e6d853ec3b2.preview-300.jpg?resize=300%2C618" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/eedition/4/db/4db8acee-36dd-556b-8647-a9229b6b8bed/61e6d853ec3b2.preview-300.jpg?resize=300%2C618" alt="" aria-hidden="true" loading="lazy" height="412" width="200"/>
         </div>
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/eedition/teton-valley-news/edition_b9f3a894-31be-51a5-bf12-ac65bd14a5e9.html" class="tnt-asset-link" aria-label="Teton Valley News">
        

        
            Teton Valley News</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-2210298" class="tncms-block"><div id="site-logo-2210298" class="site-logo-container text-center" ><div class="logo-middle">
            <a  href="/" aria-label="Home page"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/5b6a5192-6d64-11ec-a31e-bfe96a3c6131.png?resize=200%2C69" 
            srcset="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/5b6a5192-6d64-11ec-a31e-bfe96a3c6131.png?resize=150%2C51 150w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/5b6a5192-6d64-11ec-a31e-bfe96a3c6131.png?resize=200%2C69 200w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/5b6a5192-6d64-11ec-a31e-bfe96a3c6131.png?resize=225%2C77 225w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/5b6a5192-6d64-11ec-a31e-bfe96a3c6131.png?resize=300%2C103 300w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/5b6a5192-6d64-11ec-a31e-bfe96a3c6131.png 400w"
            sizes="(min-width: 1396px) 455px, calc(33.33vw - 30px)"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="400"
            height="137"
            alt="site-logo"
            ></a>
        </div><div class="logo-bottom"><div class="logo-date">
                Tuesday, January 25, 2022
            </div>
        <ul class="list-inline block-links pos-bottom ">
            
                
                    <li><a href="/eedition" class="">Print Edition</a></li>
                
            
            
        </ul></div></div></div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-2209479" class="tncms-block social"><div class="follow-links-2209479 pull-right">
    
    <section id="block-2209479" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="http://www.facebook.com/TetonValleyNews" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
        
        
        
        
            <li>
                <a href="https://www.instagram.com/tetonvalleynews/" title="Instagram" target="_blank" rel="noopener" class="btn btn-md btn-link is">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.tetonvalleynews.net",
  "sameAs" : ["http://www.facebook.com/TetonValleyNews","https://www.instagram.com/tetonvalleynews/"]
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-2210301" class="tncms-block header-weather padding-top"><div id="weather-2210301" class="weather-current size-medium pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions ">
            <a href="/weather/?weather_zip=83422" class="dropdown-toggle"  aria-label="Weather">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-night-clear"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">3&deg;</span>
                    
                        <span class="cond">Clear </span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" hamburger-desktop fluid-header navbar-toggle pull-left" data-toggle="offcanvas" data-target="left" aria-label="Left Main Menu" aria-expanded="false">
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="visible-lg visible-md sr-only-show">Menu</span>
                        </button>
                         
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left_menu_right_search">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-2210295" class="tncms-block"><div id="site-logo-2210295" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="/" aria-label="Home page"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/03767740-6d69-11ec-a31e-a71050f63159.png?resize=200%2C67" 
            srcset="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/03767740-6d69-11ec-a31e-a71050f63159.png"
            sizes="100vw"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="150"
            height="50"
            alt="site-logo"
            ></a>
        </div></div></div></div>
                            
                        </div>
                    

                    
                        <ul class="hidden-md hidden-lg nav navbar-nav pull-right site-search-full-mobile">
                            <li class="search-form-dropdown dropdown yamm-fw">
                                <a class="dropdown-toggle" data-toggle="dropdown" aria-label="Search">
                                    <span class="fas tnt-search"></span>
                                </a>
                                <ul class="dropdown-menu">
                                    <li>
                                        <form action="/search/" method="GET" class="yamm-content">
                                            <input type="hidden" name="l" value="25">
                                            <input type="hidden" name="sd" value="desc">
                                            <input type="hidden" name="s" value="start_time">
                                            <input type="hidden" name="f" value="html">
                                            <input type="hidden" name="t" value="article,video,youtube,collection">
                                            <div class="input-group">
                                                <input name="q" type="text" placeholder="Search..." title="Site Search" class="form-control" autocomplete="off">
                                                <input type="submit" class="hide" value="Search">
                                                <span class="input-group-btn">
                                                    <button class="btn btn-default site-search-btn" type="submit">
                                                        Search
                                                    </button>
                                                </span>
                                            </div>
                                            <div class="clearfix"></div>
                                        </form>
                                    </li>
                                </ul>
                            </li>
                        </ul>
                        <script>
                            $('.site-search-full-mobile button[type="submit"]').on(__tnt.client.clickEvent, function(){
                                $('.site-search-full-mobile form').submit();
                                return false;
                            });
                        </script>
                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-2210283" class="tncms-block"><ul id="site-search-2210283-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown" aria-label="Search">
                <span class="fas tnt-search"></span>
            </a>
            <ul class="dropdown-menu">
                <li><form id="site-search-2210283" aria-labelledby="site-search-button-2210283" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right normal ">
        <input id="site-search-2210283-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-2210283-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span id="site-search-button-2210283" class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-2210283-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-2210283').submit();
        return false;
    });

    $('#site-search-2210283').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-2210283 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-2210283 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-2210283-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-2210289" class="tncms-block"><div id="user-controls-2210289" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://apg05.newzware.com/ss70v2/adams/common/template.jsp?skin=tvn&nwmodule=sso&init=nonsub&nwpage=sso&rpage=https%3A%2F%2Fwww.tetonvalleynews.net%2Ftncms%2Fauth%2Fbegin%2F%3Fprovider%3DNewzware%26return%3Dhttps%253A%252F%252Fwww.tetonvalleynews.net%252Ffreeaccess%252Fvictor-teen-donates-400-covid-tests-to-community%252Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.tetonvalleynews.net/users/login/?referer_url=https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.tetonvalleynews.net/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-2210289').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.tetonvalleynews.net/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.tetonvalleynews.net/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.tetonvalleynews.net/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-2210289').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.tetonvalleynews.net/users/logout/" id="user-logout-form-2210289"><input type="hidden" name="referer_url" value="https://www.tetonvalleynews.net/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-2210292" class="tncms-block sticky-nav"><div id="user-controls-2210292" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="nav navbar-nav navbar-right"><li><a  onclick="javascript:void(0); return false;"  data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250" class="user-control-link" rel="nofollow" aria-label="Open user controls">
                        <span class="fas tnt-user"></span>
                    </a>
                    <ul class="dropdown-menu dropdown-menu-right" role="menu">
                        <li>
                            <div style="width: 300px; padding: 15px">
                                <div class="row padding-bottom">
                                    <div class="col-md-12">
                                        <h4>Log In Using Your Account</h4>
                                        <a role="menuitem" class="btn btn-block btn-primary" href="https://www.tetonvalleynews.net/users/login/?referer_url=https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" rel="nofollow">Log In</a>
                                    </div>
                                </div>
                                <div class="row">
                                    <div class="col-md-12">
                                        <div class="dropdown-signup"><strong>Don't have an account?</strong> <a role="menuitem" href="https://apg05.newzware.com/ss70v2/adams/common/template.jsp?skin=tvn&nwmodule=sso&init=nonsub&nwpage=sso&rpage=https%3A%2F%2Fwww.tetonvalleynews.net%2Ftncms%2Fauth%2Fbegin%2F%3Fprovider%3DNewzware%26return%3Dhttps%253A%252F%252Fwww.tetonvalleynews.net%252Ffreeaccess%252Fvictor-teen-donates-400-covid-tests-to-community%252Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" rel="nofollow">Sign Up Today</a></div>
                                    </div>
                                </div>
                            </div>
                        </li>
                    </ul>
                </li>
        </ul>
    </div>

    <div class="logged-in">
        
        
        <ul class="nav navbar-nav navbar-right">
            <li class="dropdown pull-right">
                
                <a class="dropdown-toggle  user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><b class="caret user-control-link"></b>
                </a>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.tetonvalleynews.net/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.tetonvalleynews.net/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.tetonvalleynews.net/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-2210292').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.tetonvalleynews.net/users/logout/" id="user-logout-form-2210292"><input type="hidden" name="referer_url" value="https://www.tetonvalleynews.net/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-2223084" class="tncms-block 0pull-right 0padding-top"><section id="block-2223084" class="block emphasis-h3   " ><div id="promo-button-2223084" class="promo-button"><a href="/subscribe/"><button type="button" class="btn  btn-sm">SUBSCRIBE</button></a></div></section></div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li>
                <a class="nav-link  nav-home  tnt-section-home"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news"  tabindex="0">
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-agriculture"  href="/news/agriculture/"  tabindex="0">
                    <span class="nav-label">Agriculture</span>
                </a></li><li>
                <a class="nav-link   tnt-section-business"  href="/news/business/"  tabindex="0">
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link   tnt-section-covid-19"  href="/news/covid19/"  tabindex="0">
                    <span class="nav-label">COVID-19</span>
                </a></li><li>
                <a class="nav-link   tnt-section-entertainment"  href="/news/entertainment/"  tabindex="0">
                    <span class="nav-label">Entertainment</span>
                </a></li><li>
                <a class="nav-link   tnt-section-education"  href="/news/education/"  tabindex="0">
                    <span class="nav-label">Education</span>
                </a></li><li>
                <a class="nav-link   tnt-section-government"  href="/news/government/"  tabindex="0">
                    <span class="nav-label">Government</span>
                </a></li><li>
                <a class="nav-link   tnt-section-housing"  href="/news/housing/"  tabindex="0">
                    <span class="nav-label">Housing</span>
                </a></li><li>
                <a class="nav-link   tnt-section-nonprofits"  href="/news/nonprofits/"  tabindex="0">
                    <span class="nav-label">Nonprofits</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-opinion"  href="/opinion"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link   tnt-section-calendar"  href="/local-events/"  tabindex="0">
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/obituaries"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-contests"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/contests/"  tabindex="0">
                    <span class="nav-label">Contests</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-free-car-payments"  href="https://tetonvalleynews.secondstreetapp.com/Free-Car-Payments-for-a-Year-5000-Sweepstakes/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Free Car Payments</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-classifieds"  href="/classifieds/"  tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-2223072" class="tncms-block 0padding-top 0padding-bottom"></div><div id="tncms-block-2223081" class="tncms-block weatheralert"></div><div id="tncms-block-2210367" class="tncms-block padding-top"><div class="tnt-ads-container text-center  " >
        <div id="ad-2210367" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2210367');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-2209389" class="tncms-block apg-center-rightrail-image apg-margin-bottom-10 text-center"><section id="block-2209389" class="block emphasis-h3   " ><div class="block"><a href="http://tvhcare.org/" rel="nofollow noopener" target="_blank" aria-label="Shop See-N-Save">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/13695a66-7e10-11ec-9e0a-8f8fa3022b76.jpg?resize=150%2C19 150w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/13695a66-7e10-11ec-9e0a-8f8fa3022b76.jpg?resize=200%2C25 200w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/13695a66-7e10-11ec-9e0a-8f8fa3022b76.jpg?resize=225%2C28 225w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/13695a66-7e10-11ec-9e0a-8f8fa3022b76.jpg?resize=300%2C37 300w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/13695a66-7e10-11ec-9e0a-8f8fa3022b76.jpg?resize=400%2C49 400w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/13695a66-7e10-11ec-9e0a-8f8fa3022b76.jpg?resize=540%2C67 540w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/13695a66-7e10-11ec-9e0a-8f8fa3022b76.jpg?resize=640%2C79 640w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/13695a66-7e10-11ec-9e0a-8f8fa3022b76.jpg 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="728"
                height="90"
                alt="Shop See-N-Save"
                ></a></div></section></div></div></div>
        </div><div id="modal-image-25370fe5-bd71-5b1d-a97e-119d0515c7d9" class="modal fullscreen in modal-image image-default modal-25370fe5-bd71-5b1d-a97e-119d0515c7d9" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-vertical letterbox-style-blur">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=400%2C534"
                    srcset="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=150%2C200 150w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=200%2C267 200w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=225%2C300 225w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=300%2C400 300w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=400%2C534 400w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=540%2C720 540w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=640%2C854 640w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=750%2C1000 750w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=990%2C1321 990w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=1035%2C1381 1035w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=1200%2C1601 1200w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=1246%2C1662 1333w"
                    sizes="100vw"
                    
                    width="1246"
                    height="1662"
                    alt="20220122_174404.jpg"
                    class="img-responsive true-size blur" />
                
                <div class="tnt-blurred-image">
             <img src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=200%2C267" alt="" aria-hidden="true" loading="lazy" height="267" width="200"/>
         </div>
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-25370fe5-bd71-5b1d-a97e-119d0515c7d9" data-target=".caption-inner-modal-image-25370fe5-bd71-5b1d-a97e-119d0515c7d9">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-25370fe5-bd71-5b1d-a97e-119d0515c7d9 collapse in"><div class="caption-text"><div class="subscriber-preview"><p>Driggs Mayor August Christensen receives a donation of 400 Covid Vault tests from Ava Kelly, 15, on Jan. 22. </p></div></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                        <li class="credit"><span  class="tnt-byline">Courtesy Photo </span></li>
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.tetonvalleynews.net%2F20220122-174404-jpg%2Fimage_25370fe5-bd71-5b1d-a97e-119d0515c7d9.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/20220122-174404-jpg/image_25370fe5-bd71-5b1d-a97e-119d0515c7d9.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"25370fe5-bd71-5b1d-a97e-119d0515c7d9"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=20220122_174404.jpg&via=http://www.twitter.com/TetonValleyNews&url=https%3A%2F%2Fwww.tetonvalleynews.net%2F20220122-174404-jpg%2Fimage_25370fe5-bd71-5b1d-a97e-119d0515c7d9.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/20220122-174404-jpg/image_25370fe5-bd71-5b1d-a97e-119d0515c7d9.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"25370fe5-bd71-5b1d-a97e-119d0515c7d9"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.tetonvalleynews.net/20220122-174404-jpg/image_25370fe5-bd71-5b1d-a97e-119d0515c7d9.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/20220122-174404-jpg/image_25370fe5-bd71-5b1d-a97e-119d0515c7d9.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"25370fe5-bd71-5b1d-a97e-119d0515c7d9"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.tetonvalleynews.net/tncms/asset/editorial/25370fe5-bd71-5b1d-a97e-119d0515c7d9" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"25370fe5-bd71-5b1d-a97e-119d0515c7d9"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTeton%20Valley%20News%5D%2020220122_174404.jpg&body=https%3A%2F%2Fwww.tetonvalleynews.net%2F20220122-174404-jpg%2Fimage_25370fe5-bd71-5b1d-a97e-119d0515c7d9.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"25370fe5-bd71-5b1d-a97e-119d0515c7d9"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/20220122-174404-jpg/image_25370fe5-bd71-5b1d-a97e-119d0515c7d9.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"25370fe5-bd71-5b1d-a97e-119d0515c7d9"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-25370fe5-bd71-5b1d-a97e-119d0515c7d9-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="25370fe5-bd71-5b1d-a97e-119d0515c7d9" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="25370fe5-bd71-5b1d-a97e-119d0515c7d9" class="save-list-25370fe5-bd71-5b1d-a97e-119d0515c7d9-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="25370fe5-bd71-5b1d-a97e-119d0515c7d9" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-25370fe5-bd71-5b1d-a97e-119d0515c7d9 img { max-height: 760px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a" class="asset article-default"  data-url="https://www.tetonvalleynews.net/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="Like many communities across the country, Teton Valley is coping with a shortage of Covid tests in the midst of an Omicron upswing. When she learned of this challenge to public health, teen philanthropist Ava Kelly of Victor decided to make a significant donation to the community: 400 Covid Vault tests, at a value of $47,000, to be distributed for free to anyone in need.  "/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?crop=1246%2C654%2C0%2C503&resize=1200%2C630&order=crop%2Cresize">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="tetonvalleynews.net">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.tetonvalleynews.net/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" />
    <style>
                .asset-paging .direction {
                    color: #27537a;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.tetonvalleynews.net\/tncms\/search\/mlt\/?origin=1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a" class="asset-paging">
                <div id="paging-prev-1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a" class="paging-link prev offset"></div>
                <div id="paging-next-1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    <div class="tow-wrapper no-flags">
        
        
    </div>
    <h1 itemprop="headline" class="headline">
        <span>
            
            Victor teen donates 400 Covid tests to community
        </span>
    </h1>
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span id="author-popup-c5b618a4-4544-11eb-8bde-5b4315e37538-asset-1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a" class="tnt-byline asset-byline" rel="popover" itemprop="author"><a href="https://www.tetonvalleynews.net/users/profile/jtellman%40tetonvalleynews.net">Julia Tellman</a></span>
                
                    <div id="author-popup-c5b618a4-4544-11eb-8bde-5b4315e37538-asset-1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a-content" class="hide">
                        <article class="clearfix card author popup-content card-author-c5b618a4-4544-11eb-8bde-5b4315e37538">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.tetonvalleynews.net/users/profile/jtellman%40tetonvalleynews.net" rel="author" class="tnt-user-profile-link tnt-user-name">jtellman@tetonvalleynews.net</a>
                                </h4></div>
                        </div>
                    </div>
                </div>
            </article>
                    </div>
                    <script>
                        $('#author-popup-c5b618a4-4544-11eb-8bde-5b4315e37538-asset-1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a').popover({
                            content: $('#author-popup-c5b618a4-4544-11eb-8bde-5b4315e37538-asset-1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a-content').html(),
                            container: 'body',
                            html:true,
                            sanitize: false,
                            trigger:'hover',
                            placement:'top',
                            delay:{ show:100, hide:200 }
                        });
                    </script>
                </li>
        
        
            <li class="visible-print">
        <time datetime="2022-01-25T09:56:00-07:00" class="tnt-date asset-date text-muted">
            Jan 25, 2022
        </time></li>
            <li class="hidden-print">
        <time datetime="2022-01-25T09:56:00-07:00" class="tnt-date asset-date text-muted">13 hrs ago</time></li>
        
        
            <li class="hidden-print"><a href="https://www.tetonvalleynews.net/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html#comments" class="cm"><span class="fas tnt-comments"></span> <span twt-comment-count="https://www.tetonvalleynews.net/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" twt-article-id="1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2022-01-25T09:56:00-07:00">
    <meta itemprop="datePublished" content="2022-01-25T09:56:00-07:00">
    <meta itemprop="dateModified" content="2022-01-25T09:56:00-07:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Victor%20teen%20donates%20400%20Covid%20tests%20to%20community&via=http://www.twitter.com/TetonValleyNews&url=https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.tetonvalleynews.net/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.tetonvalleynews.net/tncms/asset/editorial/1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTeton%20Valley%20News%5D%20Victor%20teen%20donates%20400%20Covid%20tests%20to%20community&body=https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-vertical hover-expand letterbox-style-blur"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-25370fe5-bd71-5b1d-a97e-119d0515c7d9" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-25370fe5-bd71-5b1d-a97e-119d0515c7d9" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1246">
            <meta itemprop="height" content="1662">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=500%2C667">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=500%2C667">
        <img
                    src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=400%2C534"
                    srcset="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=150%2C200 150w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=200%2C267 200w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=225%2C300 225w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=300%2C400 300w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=400%2C534 400w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=540%2C720 540w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=640%2C854 640w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=750%2C1000 750w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=990%2C1321 990w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=1035%2C1381 1035w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=1200%2C1601 1200w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=1246%2C1662 1333w"
                    sizes="(min-width: 1396px) 881px, (min-width: 992px) calc(66.70vw - 60px), calc(100vw - 30px)"
                    
                    width="1246"
                    height="1662"
                    alt="20220122_174404.jpg"
                    class="img-responsive  letterbox tnt-restrict-img-25370fe5-bd71-5b1d-a97e-119d0515c7d9 blur" />
            </div><style>
                .tnt-restrict-img-25370fe5-bd71-5b1d-a97e-119d0515c7d9 {
                    max-width: 570px;
                }
            </style>
                
                <div class="tnt-blurred-image">
             <img src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/editorial/2/53/25370fe5-bd71-5b1d-a97e-119d0515c7d9/61f02f9f3e2f9.image.jpg?resize=200%2C267" alt="" aria-hidden="true" loading="lazy" height="267" width="200"/>
         </div>
            </div>
            
                
                
                    <figcaption class="caption">
                            
                                <span class="caption-text">
                                    <p>Driggs Mayor August Christensen receives a donation of 400 Covid Vault tests from Ava Kelly, 15, on Jan. 22. </p>
                                </span>
                            
                        
                            
                                <span class="credit">
                                    <span  class="tnt-byline">Courtesy Photo </span>
                                </span>
                            
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div>

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a" data-smart-adunit="/132916964,22591864201/tetonvalleynews.net/freeaccess">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Victor%20teen%20donates%20400%20Covid%20tests%20to%20community&via=http://www.twitter.com/TetonValleyNews&url=https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.tetonvalleynews.net/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.tetonvalleynews.net/tncms/asset/editorial/1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTeton%20Valley%20News%5D%20Victor%20teen%20donates%20400%20Covid%20tests%20to%20community&body=https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a" class="save-list-1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="false"/>
                                
                                
                                <div class="subscriber-preview"><p>Like many communities across the country, Teton Valley is coping with a shortage of Covid tests in the midst of an <a href="https://www.tetonvalleynews.net/news/covid19/with-rise-in-covid-cases-county-victor-and-driggs-require-masks-in-some-areas/article_b66773c1-cabd-58cf-aff3-3817d59a6e49.html" target="_blank">Omicron upswing</a>. When she learned of this challenge to public health, teen philanthropist Ava Kelly of Victor decided to make a significant donation to the community: 400 Covid Vault tests, at a value of $47,000, to be distributed for free to anyone in need. </p></div><div class="subscriber-preview"><p>In 2019, after becoming the youngest certified yoga instructor in the region, Kelly launched the nonprofit Ava Marie Yogi to support mental health through yoga, meditation, and other physical activity. Since then, her philanthropy has had an impact across Teton Valley. At the end of 2020, Kelly made a <a href="https://www.tetonvalleynews.net/news/covid19/teen-philanthropists-donation-helps-to-facilitate-open-skate/article_d9c31aae-3ec1-54ca-8c73-391b2c62b659.html" target="_blank">similar donation of Covid tests to the Teton Valley Foundation</a> to enable the nonprofit to restart open skate sessions at the Kotler Ice Arena. </p></div><div class="subscriber-only"><p>Teton County, Teton Valley Health, and the three local cities accepted the donation on Jan. 22 and worked together to organize distribution of the at-home tests. </p></div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><div class="subscriber-only"><p>"We would like to express our most sincere appreciation to Ava Marie Yogi for this incredibly generous donation to the public health of our community," county emergency management coordinator Greg Adams said in a Tuesday press release. "We also wish to thank the residents of Teton County for your continued efforts to protect each other through this pandemic." </p></div><div class="subscriber-only"><p>Tests are available for free starting on Tuesday, Jan. 25 at Victor Clinic, Driggs Clinic, and Tetonia City Hall. </p></div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            <div id="tncms-region-asset-native-advertising" class="tncms-region "></div>
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Victor%20teen%20donates%20400%20Covid%20tests%20to%20community&via=http://www.twitter.com/TetonValleyNews&url=https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.tetonvalleynews.net/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.tetonvalleynews.net/tncms/asset/editorial/1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTeton%20Valley%20News%5D%20Victor%20teen%20donates%20400%20Covid%20tests%20to%20community&body=https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a" class="save-list-1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22ava%20kelly%22#tncms-source=keyword" class="tag-ava-kelly label label-default" data-tncms-track-dmp='search: ava-kelly'>Ava Kelly</a>
            </li> <li>
                <a href="/search/?k=%22teton%20valley%20foundation%22#tncms-source=keyword" class="tag-teton-valley-foundation label label-default" data-tncms-track-dmp='search: teton-valley-foundation'>Teton Valley Foundation</a>
            </li> <li>
                <a href="/search/?k=%22economics%22#tncms-source=keyword" class="tag-economics label label-default" data-tncms-track-dmp='search: economics'>Economics</a>
            </li> <li>
                <a href="/search/?k=%22sport%22#tncms-source=keyword" class="tag-sport label label-default" data-tncms-track-dmp='search: sport'>Sport</a>
            </li> <li>
                <a href="/search/?k=%22donation%22#tncms-source=keyword" class="tag-donation label label-default" data-tncms-track-dmp='search: donation'>Donation</a>
            </li> <li>
                <a href="/search/?k=%22test%22#tncms-source=keyword" class="tag-test label label-default" data-tncms-track-dmp='search: test'>Test</a>
            </li> <li>
                <a href="/search/?k=%22covid%20vault%22#tncms-source=keyword" class="tag-covid-vault label label-default" data-tncms-track-dmp='search: covid-vault'>Covid Vault</a>
            </li> <li>
                <a href="/search/?k=%22ava%20marie%20yogi%22#tncms-source=keyword" class="tag-ava-marie-yogi label label-default" data-tncms-track-dmp='search: ava-marie-yogi'>Ava Marie Yogi</a>
            </li> <li>
                <a href="/search/?k=%22teen%22#tncms-source=keyword" class="tag-teen label label-default" data-tncms-track-dmp='search: teen'>Teen</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    
                        
                            <div class="asset-author">
                                <article class="clearfix card author  card-author-c5b618a4-4544-11eb-8bde-5b4315e37538">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.tetonvalleynews.net/users/profile/jtellman%40tetonvalleynews.net" rel="author" class="tnt-user-profile-link tnt-user-name">jtellman@tetonvalleynews.net</a>
                                </h4><div class="followed-notify-link hidden-print"><button id="follow-author-c5b618a4-4544-11eb-8bde-5b4315e37538" class="followed-notify-btn btn btn-success btn-sm" disabled data-params="?a=c5b618a4-4544-11eb-8bde-5b4315e37538&amp;s=start_time&amp;sd=desc" data-subject="jtellman@tetonvalleynews.net" data-description="Whenever jtellman@tetonvalleynews.net posts new content, you'll get an email delivered to your inbox with a link." data-name="jtellmantetonvalleynewsnet notification" data-author-id="c5b618a4-4544-11eb-8bde-5b4315e37538" data-user-url="https://www.tetonvalleynews.net/users/">
        <i class="fas tnt-star"></i> Follow jtellman@tetonvalleynews.net
    </button><template id="follow-this-modal-logged-in">
            <div class="modal-dialog">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Get email notifications on {{subject}} daily!</h4>
                    </div>
                    <div class="modal-body">
                        <div class="alert alert-success" style="display:none;">
                            Your notification has been saved.
                        </div>
                        <div class="alert alert-danger" style="display:none;">
                            There was a problem saving your notification.
                        </div>
                        <p class="notification-description">{{description}}</p>
                        <p>Email notifications are only sent once a day, and only if there are new matching items.</p>
                        <form id="follow-notify-form" class="follow-notify-form" action="{{action}}" method="post">
                            <input class="input-notification-name" type="hidden" name="title" value="{{title}}">
                            <div class="row">
                                <div class="col-sm-6">
                                    <button class="btn btn-success btn-block follow-btn" data-tncms-track-dmp='is_followed_notifications_user'>
                                        <i class="fas tnt-spinner tnt-pulse" style="display:none;"></i> Save
                                    </button>
                                </div>
                                <div class="col-sm-6">
                                    <a class="btn btn-default btn-block" href="https://www.tetonvalleynews.net/users/admin/savedsearch/">Manage followed notifications</a>
                                </div>
                            </div>
                        </form>
                    </div>
                </div>
            </div>
        </template>

        <template id="follow-this-modal-logged-out">
            <div class="modal-dialog modal-sm">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Followed notifications</h4>
                    </div>
                    <div class="modal-body">
                        <div class="user-login padding-bottom">
                            <h4>Please log in to use this feature</h4>
                            <a class="btn btn-block btn-primary" href="https://www.tetonvalleynews.net/users/login/?referer_url=https%3A%2F%2Fwww.tetonvalleynews.net%2Ffreeaccess%2Fvictor-teen-donates-400-covid-tests-to-community%2Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" rel="nofollow">Log In</a>
                        </div>
                        <div class="user-signup">
                            <strong>Don't have an account?</strong> <a href="https://apg05.newzware.com/ss70v2/adams/common/template.jsp?skin=tvn&nwmodule=sso&init=nonsub&nwpage=sso&rpage=https%3A%2F%2Fwww.tetonvalleynews.net%2Ftncms%2Fauth%2Fbegin%2F%3Fprovider%3DNewzware%26return%3Dhttps%253A%252F%252Fwww.tetonvalleynews.net%252Ffreeaccess%252Fvictor-teen-donates-400-covid-tests-to-community%252Farticle_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" rel="nofollow">Sign Up Today</a>
                        </div>
                    </div>
                </div>
            </div>
        </template>

        <div id="follow-this-modal" class="modal fade follow-this-modal">
            <div class="modal-dialog"></div>
        </div></div></div>
                        </div>
                    </div>
                </div>
            </article>
                            </div>
                        
                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-2209287" class="tncms-block"><div id="nativo-inside"></div></div><div id="tncms-block-2209290" class="tncms-block"><section id="block-2209290" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-2209290 ">
        <div class="block-title-inner">
            <h3>
                
                Recommended for you
                
            </h3>
        </div>
    </div></div><div id="card-grid-behavioral-2209290" class="card-grid-behavioral card-grid card-img- card-compact"  data-lotame-track="true"><div class=" row equal equal-wrap"><div id="tncms-recommendations-2209290" class="recommendations-container"></div>
            <div class="clearfix hidden-xs"></div>
            </div>
        </div></section></div></div>

                    <div class="asset-comments hidden-print">
                <div id="comments-container" class="comments-container">
                    
                    <div id="comments">
                        <div id="twt-comments"></div>
                        
                    </div>
                </div>
            
        </div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-2210370" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-2210370" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2210370');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-2210256" class="tncms-block"><section id="block-2210256" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-2210256 ">
        <div class="block-title-inner">
            <h4>
                
                Trending Now
                
            </h4>
        </div>
    </div></div>
    <div class="card">
        <ul class="list-unstyled list-popular bold"><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/freeaccess/victor-teen-donates-400-covid-tests-to-community/article_1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a.html" class="tnt-asset-link" aria-label="Victor teen donates 400 Covid tests to community">
        

        
            Victor teen donates 400 Covid tests to community</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/news/business/pinky-gs-opens-third-pizzeria-in-victor/article_a04d8894-774b-5a9a-85ba-84e9f0e3d5da.html" class="tnt-asset-link" aria-label="Pinky G's opens third pizzeria in Victor">
        

        
            Pinky G's opens third pizzeria in Victor</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/community/sheriffs_log/sheriffs-log---january-19/article_224a803c-2e8f-5a04-83cf-26386b2dc690.html" class="tnt-asset-link" aria-label="Sheriff's Log - January 19">
        

        
            Sheriff's Log - January 19</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/freeaccess/friends-and-family-fundraising-for-leland-christensen/article_c81a261b-9ec3-5e84-afe9-6f2287bd7412.html" class="tnt-asset-link" aria-label="Friends and family fundraising for Leland Christensen">
        

        
            Friends and family fundraising for Leland Christensen</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/community/victors-nathan-mortenson-wins-helmet-design-competition-for-victor-olympian-breezy-johnson/article_1d22655a-d7b3-5644-9a31-c6619b01ac67.html" class="tnt-asset-link" aria-label="Victor's Nathan Mortenson wins helmet design competition for Victor Olympian Breezy Johnson">
        

        
            Victor's Nathan Mortenson wins helmet design competition for Victor Olympian Breezy Johnson</a></h5>
                    
                </li></ul>
    </div>
    
</section></div><div id="tncms-block-2256667" class="tncms-block apg-center-rightrail-image apg-margin-bottom-10"><section id="block-2256667" class="block emphasis-h3   " ><div class="block"><a href="https://www.grandtarghee.com/lesson-rentals/ski-snowboard-school/adult-ski-snowboard-lessons/?utm_source=Start+Me+up&utm_medium=Display+Banner+Ad&utm_campaign=Lessons&utm_id=TVN&utm_term=Lessons&utm_content=Lessons" rel="nofollow noopener" target="_blank" aria-label="Grand Targhee Ski and Snowboard Lessons">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/8129c93e-7ae4-11ec-b589-9f96f7fab32c.png?resize=150%2C125 150w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/8129c93e-7ae4-11ec-b589-9f96f7fab32c.png?resize=200%2C167 200w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/8129c93e-7ae4-11ec-b589-9f96f7fab32c.png?resize=225%2C188 225w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/8129c93e-7ae4-11ec-b589-9f96f7fab32c.png 300w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="300"
                height="250"
                alt="Grand Targhee Ski and Snowboard Lessons"
                ></a></div></section></div><div id="tncms-block-2268346" class="tncms-block apg-center-rightrail-image apg-margin-bottom-10"><section id="block-2268346" class="block emphasis-h3   " ><div class="block"><a href="https://www.ahjacksonhole.com/work-with-us/" rel="nofollow noopener" target="_blank" aria-label="Akin & Hedges Realty">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/8ce4f8da-7b06-11ec-a78d-f3d2ea46356a.jpg?resize=150%2C125 150w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/8ce4f8da-7b06-11ec-a78d-f3d2ea46356a.jpg?resize=200%2C167 200w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/8ce4f8da-7b06-11ec-a78d-f3d2ea46356a.jpg?resize=225%2C188 225w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/8ce4f8da-7b06-11ec-a78d-f3d2ea46356a.jpg 300w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="300"
                height="250"
                alt="Akin &amp; Hedges Realty"
                ></a></div></section></div><div id="tncms-block-2283958" class="tncms-block apg-center-rightrail-image apg-margin-bottom-10"><section id="block-2283958" class="block emphasis-h3   " ><div class="block"><a href="https://www.compass.com/homes-for-sale/teton-county-id/mapview=44.5886007,-109.6665643,43.6679625,-111.2705683/" rel="nofollow noopener" target="_blank" aria-label="Compass Realty">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/3fd19794-7e10-11ec-96e9-23f9cf8d2241.jpg?resize=150%2C125 150w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/3fd19794-7e10-11ec-96e9-23f9cf8d2241.jpg?resize=200%2C167 200w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/3fd19794-7e10-11ec-96e9-23f9cf8d2241.jpg?resize=225%2C188 225w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/3fd19794-7e10-11ec-96e9-23f9cf8d2241.jpg 300w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="300"
                height="250"
                alt="Compass Realty"
                ></a></div></section></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-2210373" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-2210373" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2210373');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-2209416" class="tncms-block promobox eedition-latest"><section id="block-2209416" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-2209416 ">
        <div class="block-title-inner">
            <h4>
                
                    <a href="/eedition">
                
                Latest E-Edition
                
                    </a>
                
            </h4>
        </div>
    </div></div>
    
        <article id="card-summary-b9f3a894-31be-51a5-bf12-ac65bd14a5e9" class="clearfix card summary">
                <div class="card-container">
                        <div class="card-image">
                            <div class="media-preview-b9f3a894-31be-51a5-bf12-ac65bd14a5e9 media-preview edition-asset " data-aspect=""><figure class="photo layout-vertical letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/eedition/teton-valley-news/edition_b9f3a894-31be-51a5-bf12-ac65bd14a5e9.html" class="tnt-asset-link"  aria-label="Teton Valley News">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Teton Valley News"
                            class="img-responsive lazyload full blur"
                            width="300"
                            height="618"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/eedition/4/db/4db8acee-36dd-556b-8647-a9229b6b8bed/61e6d853ec3b2.preview-300.jpg?resize=150%2C309 150w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/eedition/4/db/4db8acee-36dd-556b-8647-a9229b6b8bed/61e6d853ec3b2.preview-300.jpg?resize=200%2C412 200w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/eedition/4/db/4db8acee-36dd-556b-8647-a9229b6b8bed/61e6d853ec3b2.preview-300.jpg?resize=225%2C464 225w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/eedition/4/db/4db8acee-36dd-556b-8647-a9229b6b8bed/61e6d853ec3b2.preview-300.jpg?resize=300%2C618 300w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/eedition/4/db/4db8acee-36dd-556b-8647-a9229b6b8bed/61e6d853ec3b2.preview-300.jpg?resize=300%2C618" alt="" aria-hidden="true" loading="lazy" height="412" width="200"/>
         </div>
            </div>
            
        </figure></div>
                        </div>
                    <div class="card-body">
                        <div class="card-headline">
                            <h3 class="tnt-headline ">
        
             <a href="/eedition/teton-valley-news/edition_b9f3a894-31be-51a5-bf12-ac65bd14a5e9.html" class="tnt-asset-link" aria-label="Teton Valley News">
        

        
            Teton Valley News</a></h3>
                        </div>
                            <div class="card-meta">
                                <ul class="list-inline">
                                    
                                    
                                        <li style="padding-bottom:10px;">Read the latest edition of the Teton Valley News.</li>
                                    </ul>
                            </div>
                    </div>
                </div>
                <div class="clearfix"></div>
            </article>
    
    </section></div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-2210376" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-2210376" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2210376');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-2209461" class="tncms-block promobox eedition-latest"><section id="block-2209461" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-2209461 ">
        <div class="block-title-inner">
            <h4>
                
                    <a href="/eedition/special_sections">
                
                Latest Special Sections
                
                    </a>
                
            </h4>
        </div>
    </div></div>
    
        <article id="card-summary-a339d8ed-168d-560f-9372-7b55faf682fb" class="clearfix card summary">
                <div class="card-container">
                        <div class="card-image">
                            <div class="media-preview-a339d8ed-168d-560f-9372-7b55faf682fb media-preview edition-asset " data-aspect=""><figure class="photo layout-vertical letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/eedition/special_sections/sports-and-recreation-2020/edition_a339d8ed-168d-560f-9372-7b55faf682fb.html" class="tnt-asset-link"  aria-label="Sports and Recreation 2020">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Sports and Recreation 2020"
                            class="img-responsive lazyload full blur"
                            width="300"
                            height="375"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/eedition/1/aa/1aa6b494-d0b9-5afb-83aa-bce12956e794/5e4efa23888c3.preview-300.jpg?resize=150%2C188 150w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/eedition/1/aa/1aa6b494-d0b9-5afb-83aa-bce12956e794/5e4efa23888c3.preview-300.jpg?resize=200%2C250 200w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/eedition/1/aa/1aa6b494-d0b9-5afb-83aa-bce12956e794/5e4efa23888c3.preview-300.jpg?resize=225%2C281 225w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/eedition/1/aa/1aa6b494-d0b9-5afb-83aa-bce12956e794/5e4efa23888c3.preview-300.jpg?resize=300%2C375 300w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/assets/v3/eedition/1/aa/1aa6b494-d0b9-5afb-83aa-bce12956e794/5e4efa23888c3.preview-300.jpg?resize=300%2C375" alt="" aria-hidden="true" loading="lazy" height="250" width="200"/>
         </div>
            </div>
            
        </figure></div>
                        </div>
                    <div class="card-body">
                        <div class="card-headline">
                            <h3 class="tnt-headline ">
        
             <a href="/eedition/special_sections/sports-and-recreation-2020/edition_a339d8ed-168d-560f-9372-7b55faf682fb.html" class="tnt-asset-link" aria-label="Sports and Recreation 2020">
        

        
            Sports and Recreation 2020</a></h3>
                        </div>
                            <div class="card-meta">
                                <ul class="list-inline">
                                    
                                    
                                        <li style="padding-bottom:10px;">Read the latest special sections.</li>
                                    </ul>
                            </div>
                    </div>
                </div>
                <div class="clearfix"></div>
            </article>
    
    </section></div><div id="tncms-block-2209413" class="tncms-block"><iframe src="https://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.facebook.com%2FTetonValleyNews%2F&amp;width=450&amp;layout=standard&amp;action=like&amp;size=large&amp;show_faces=true&amp;share=true&amp;height=80&amp;appId" width="450" height="80" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowtransparency="true"></iframe></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"><div id="tncms-block-2210388" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-2210388" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2210388');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-2210361" class="tncms-block padding-bottom footer-logo"><div id="site-logo-2210361" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="/" aria-label="Home page"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/116417a8-61d0-11ec-9099-b76438485136.png?resize=200%2C146" 
            srcset="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/116417a8-61d0-11ec-9099-b76438485136.png?resize=150%2C110 150w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/116417a8-61d0-11ec-9099-b76438485136.png?resize=200%2C146 200w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/116417a8-61d0-11ec-9099-b76438485136.png?resize=225%2C164 225w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/116417a8-61d0-11ec-9099-b76438485136.png?resize=300%2C219 300w, https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/content/tncms/custom/image/116417a8-61d0-11ec-9099-b76438485136.png 400w"
            sizes="(min-width: 1396px) 455px, calc(33.33vw - 30px)"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="400"
            height="292"
            alt="site-logo"
            ></a>
        </div></div></div><div id="tncms-block-2210364" class="tncms-block social-links padding-top padding-bottom"><div class="follow-links-2210364 default">
    
    <section id="block-2210364" class="block emphasis-h4   " ><ul class="list-inline">
        
            <li>
                <a href="http://www.facebook.com/TetonValleyNews" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/tetonvalleynews/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.tetonvalleynews.net",
  "sameAs" : ["http://www.facebook.com/TetonValleyNews","https://twitter.com/tetonvalleynews/"]
}
</script>
<div class="clearfix"></div></div></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-2210349" class="tncms-block"><section id="block-2210349" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-2210349 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link  nav-home  tnt-section-home"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link   tnt-section-news"  href="/news/"  tabindex="0">
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports/"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-opinion"  href="/opinion/"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/obituaries/"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-local-events"  href="/local-events/"  tabindex="0">
                    <span class="nav-label">Local Events</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weather"  href="/weather/"  tabindex="0">
                    <span class="nav-label">Weather</span>
                </a></li><li>
                <a class="nav-link   tnt-section-rss"  href="/site/rss"  tabindex="0">
                    <span class="nav-label">Rss</span>
                </a></li><li>
                <a class="nav-link   tnt-section-archives"  href="https://apgwest.newsbank.com/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Archives</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-2209305" class="tncms-block"><section id="block-2209305" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-2209305 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Us
                
            </h4>
        </div>
    </div></div></section></div><div id="tncms-block-2209308" class="tncms-block"><section id="block-2209308" class="block emphasis-h3   " ><address>
    <strong>tetonvalleynews.net</strong><br>
    75 N. Main Street<br>
    Driggs, ID 83422
    <br>
    
        <strong>Phone:</strong> (208) 231-8747<br>
        <strong>Email:</strong> <a href="mailto:candersen@tetonvalleynews.net">candersen@tetonvalleynews.net</a><br>
    
</address></section></div><div id="tncms-block-2210352" class="tncms-block"><section id="block-2210352" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-2210352 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-three-nav" class="tncms-region-nav"><ul id="footer-col-three-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about/"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact/"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-promote-your-event"  href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=TETONVALLEYNEWS&amp;publisher_url:tetonvalleynews.net#/quick"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Promote Your Event</span>
                </a></li></ul></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
    

            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-2210358" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-2210358"><div class="col-md-7"><small>&copy; Copyright 2022 <a href="/">Teton Valley News</a>, 75 N. Main Street Driggs, ID</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div><div id="tncms-block-2209299" class="tncms-block"><style>
#masthead-col-one {
    width: 25%;
}
#masthead-col-two {
    width: 50%;
}
#masthead-col-three {
    width: 25%;
}
/* FOOTER STYLES - 2017 Redesign */
#tncms-region-footer-bottom-col-full {
    margin-top:24px;
}
#site-footer-container {
    background-color: #222222!important;
    background-image: none!important;
    color: #bbb;
}
#site-footer, #site-copyright, #site-footer .block-title h4 {
    color: #bbb;
}
#site-upper-footer-wrap {
  background-color: #555; }

#site-lower-footer-wrap {
  background-color: #222; }

#site-upper-footer, #site-lower-footer {
  padding-top: 20px;
  background-color: transparent; }

.footerContainer {
  background-color: transparent;
  font-family: "Open Sans", sans-serif;
  font-weight: 400;
  font-size: 14px;
  line-height: 21px; }
  .footerContainer .footer-col {
    padding: 0 10px;
    margin: 0 0 20px;
    box-sizing: border-box; }
  .footerContainer .col-heading {
    text-transform: uppercase;
    letter-spacing: 0.05em;
    font-weight: 700;
    color: #fff;
    margin-bottom: 3px; }
  .footerContainer .col-item {
    letter-spacing: 0.02em;
    color: #bbb; }
    .footerContainer .col-item.col-item-highlight {
      color: #fff;
      font-weight: 700; }
    .footerContainer .col-item a, #site-footer a, #site-copyright a {
      letter-spacing: 0.02em;
      color: #bbb;
      text-decoration: none;
      -webkit-transition: all 200ms ease;
      transition: all 200ms ease; }
      .footerContainer .col-item a:hover, #site-footer a:hover, #site-copyright a:hover {
        color: #fff;
        text-decoration: underline; }
  .footerContainer .footer-col-list {
    list-style: none; }
    .footerContainer .footer-col-list.footer-col-png-list {
      column-count: 3; }
      @media all and (max-width: 991px) {
        .footerContainer .footer-col-list.footer-col-png-list {
          column-count: 2; } }
      @media all and (max-width: 768px) {
        .footerContainer .footer-col-list.footer-col-png-list {
          column-count: 1; } }
  .footerContainer .footer-col-info {
    list-style: none; }
    .footerContainer .footer-col-info .footer-col-info-basic {
      margin-bottom: 12px; }
    .footerContainer .footer-col-info .footer-col-info-social .col-item-icon {
      display: inline-block;
      margin: 6px 6px 0 0; }
      .footerContainer .footer-col-info .footer-col-info-social .col-item-icon:last-of-type {
        margin: 6px 0 0 0; }
      .footerContainer .footer-col-info .footer-col-info-social .col-item-icon a {
        font-size: 24px;
        color: #bbb;
        text-decoration: none;
        -webkit-transition: all 200ms ease;
        transition: all 200ms ease; }
        .footerContainer .footer-col-info .footer-col-info-social .col-item-icon a:hover {
          color: #fff; }
  .footerContainer .png-logo-wrap {
    padding-left: 0px;
    padding-right: 0px; }

</style></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("1fcf5eb8-6f73-5446-9d95-d9ab0a3e144a")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                _cc9940.add('act', dmpData);_cc9940.bcp();
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ dataLayer.push({
            'tncms.asset.sections': ["freeaccess", "coronavirus", "news/covid19", "townnews/economics", "townnews/sport", "top_story"],
            'tncms.asset.flags': [""],
            'tncms.asset.keywords': ["ava kelly", "teton valley foundation", "economics", "sport", "donation", "test", "covid vault", "ava marie yogi", "teen"]
        }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.google.survey.f62819b485e5f0a32cee78210d157aca.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.3.1.aa9875a0eb3a786200a6d1ea6f239a63.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.granted.3.1.f1d4316608d71880756ca7cad8752a2a.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.user.modal.2a14b2d3f868a8e45b3bf1708ce3ce8a.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.user.modal.wall.e7694fa6be0fbe630a2d207c52743ee9.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.denied.4.0.offers.eede44737e0335323770692648834db2.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.validate.f4d73313b7ce7a32500a94c38e2d2ca2.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/additional-methods.54cac72c4ecc4fe6191818374fa8d218.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.validate.custom-methods.7529deb5615a27af839a4621b5b71896.js"></script>
<script>/*<![CDATA[*/ 
        document.getElementById('user-password-toggle').addEventListener('click', function() {
            var passInput = document.getElementById('user-password'),
                passToggle = document.getElementById('user-password-toggle'),
                passIcon = passToggle.getElementsByClassName('tnt-svg')[0];
            if (passInput.type === 'password') {
                passInput.type = 'text';
                passIcon.classList.replace('tnt-eye', 'tnt-eye-slash');
            } else {
                passInput.type = 'password';
                passIcon.classList.replace('tnt-eye-slash', 'tnt-eye');
            }
        }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            var account = sessionStorage.getItem("forgotAccount");
            if (account && typeof account === "string" && account.length > 0) {
                document.getElementById("user-username").value = account;
            }
         /*]]>*/</script>
<script>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</script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.output.subscription.8ef15e98666881780fc35aad3af5f594.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.output.laterpay.7a6e72d83c11470ac72ce2b2f5d9fdbd.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.output.customjs.1480f2a51e2939dd767e130e3406e489.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.fa820af8c4b7651b60faff4dca7ed722.js"></script>
<script>/*<![CDATA[*/ 
                        !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt);
                    document.addEventListener('DOMContentLoaded', function() {
                        var isIOS = /iPad|iPhone|iPod/.test(navigator.userAgent) && !window.MSStream;
                        if (isIOS) {
                            Array.from(document.querySelectorAll('[data-toggle="offcanvas"]')).forEach(function(drawer) {
                                drawer.addEventListener("mouseover", function(e) {
                                    var drawerCls = drawer.dataset.target === 'left' ? 'active-left' : 'active-right';
                                    document.documentElement.classList.add('drawer-open', drawerCls);
                                })
                            })
                        }
                    }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/withinviewport.1f94ee79a22e6ee8e9c0bb61dec9999b.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.withinviewport.6ef0fee1774e9b313c264a5736522e35.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.scrollstop.934c2bd4d6bebe0494bcb9dd4b1b6ca1.js"></script>
<script>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</script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sticky-kit.136ae7f2f818eb47f6ccd0348c560674.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/tetonvalleynews.net/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.54d9f15b0d238de6bb20ec82ed8307ac.js"></script>
<script>/*<![CDATA[*/ (function() {
                    window.addEventListener('load', function() {
                        __tnt.regions.stickySide.init(document.getElementById('sticky-right-rail'), document.getElementById('sticky-right-rail-spacer'), 'siderail', '.row');
                    });
                })(); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            jQuery(document).ready(function($){
                var iqLogin = Cookies.get('tnt-iq-login') || false;
                if (__tnt.user.loggedIn && iqLogin == false) {
                    if (__tnt.user.services) {
                        var userServices = __tnt.user.services.split(',');
                        for (i = 0; i < userServices.length; i++) { 
                            var serviceData = 'has_subservice: ' + userServices[i];
                            _cc9940.add('act', serviceData);_cc9940.bcp();
                        }
                    }
                    Cookies.set('tnt-iq-login', 1);
                }
            });
        
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        _cc9940.add('act', dmpData);_cc9940.bcp();
                    }
                }
            }
         /*]]>*/</script></body>
</html>